Solved: Vista hardware detection problem

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Pinaar

Thread Starter
Joined
Aug 30, 2006
Messages
275
Hi,
Had a problem with 1 of our laptops and had to do a complete restore, when it all came back to running I can't get an internet connection. If I go to the wireless connection my network is listed but after inputting keyword phrase it can't connect. If I go to "set up a connection" > "set up a wireless router" Windows does not detect any wireless network hardware.
I can connect if I plug in the ethernet cable directly and this laptop was connecting perfectly to this router before the crash and restore.
 

TerryNet

Terry
Moderator
Joined
Mar 23, 2005
Messages
81,424
Have you installed the latest wireless driver (from the laptop manufacturer for an integrated adapter & from the card manufacturer for an external card)?

Disable encryption on the router and try to connect. If successful you can probably re-enable encryption and reconnect.
 

Pinaar

Thread Starter
Joined
Aug 30, 2006
Messages
275
Have tried but keep getting pushed round in circles. Don't get how it's finding the network but can't connect but also says can't detect the hardware. How is it picking up the network if it can't find the hardware to do it.
 

Pinaar

Thread Starter
Joined
Aug 30, 2006
Messages
275
Just found 106 windows updates, I'll let them download and then check the drivers and see if anything changes, may be a while.
Didn't really want to mess with the router as it's quite new and has been working perfectly up till now - touch wood, hope that's not the kiss of death.
 

Pinaar

Thread Starter
Joined
Aug 30, 2006
Messages
275
Quick update, downloaded all 106 windows updates and updated wireless drivers from the site. All seems to be sorted now thanks everyone who helped.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top