Solved: Windows Not Seeing My New External Drive

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

xmf

Thread Starter
Joined
Jul 31, 2009
Messages
203
I have a brand new Seagate 160gb drive (that I installed into the proper SATA external case). When I plug in the USB, the Windows "Safely Remove Hardware" icon appears in the tray, however, the drive doesn't appear in "My Computer".

The only think I can think of is that I removed the Universal Plug and Play service on this install.
 
Joined
Oct 3, 2007
Messages
7,889
Check disk management, it may need to be partitioned and formatted before windows explorer can see it.

.
 
Joined
Oct 3, 2007
Messages
7,889
Please mark this thread :"Solved" by using the solved button just above your first post.

You are Welcome. :- )

.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top