Solved: windows8 and XP Pro

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

ayawar

Thread Starter
Joined
Dec 23, 2012
Messages
6
Hi,

I have a fairly old laptop with winxp.
Just got myself a new Samsung that came with preinstalled Windows8

I decided I'll set it up and use the winxp as a file server/download station where I could stream directly from rather than clutter the new win8

In XP - I enabled file sharing. I right clicked a folder on my desktop, shared it (simple file sharing)
Win8 - Asked me if its a home/work network or public - marked home/work.

They couldn't see each other till I renamed both workgroups to "2012"

I could now access my XP shared folder, read/write - all good till here.

walked out for 10mins, now they're acting weird. they can either not see each other or i get the "not accessible" error :confused:

XP - I've tried disabling simple file sharing, using permissions.. no change. Enabled NetBios over tcp/ip
still no joy

any suggestions please??
 

ayawar

Thread Starter
Joined
Dec 23, 2012
Messages
6
Additional info - both have same username and password
Also - i just tried restarting both machines, 1 out of 5 times they can see each other and access shared files, connection drops after 10min of leaving them idle
 

ayawar

Thread Starter
Joined
Dec 23, 2012
Messages
6
new update -
turns out, when i restart my wireless router, the connection stays for as long as 40mins (since i've rebooted it)
 

TerryNet

Terry
Moderator
Joined
Mar 23, 2005
Messages
81,392
Are you sure that neither PC is disconnecting from the network because of a--even momentary--lost connection or going to sleep/standby or into hibernation?

Any change to the network, such as the above, can mean that at least some computers will not have up-to-date network information for 20 minutes or so. During this time, if this is happening, you will be able to ping or access other machines by IP address but not by name.
 

ayawar

Thread Starter
Joined
Dec 23, 2012
Messages
6
i'm sure the connection is stable
also neither go on sleep/standby or hibernation

winxp to another winxp - connection is perfect

could it be windows8? or maybe the wireless router?

edit - additional info, wireless router is used by 5 other computers in the house who connect to it, to use the internet
 

TerryNet

Terry
Moderator
Joined
Mar 23, 2005
Messages
81,392
Yes, it could be an unusual router problem. Make sure you have the latest firmware; then reset it to factory defaults and reconfigure it.
 

ayawar

Thread Starter
Joined
Dec 23, 2012
Messages
6
***FIXED***

If this helps anyone,

cmd prompt,
net config server /autodisconnect:-1

This changed the registry key in both computers to disable autodisconnect if the computers are idle.

(HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Service\lanmanworkstation\parameters)

Worked well, left both xp and w8 idle overnight and w8 still maintains connection.

There is also another key "KeepConn" I know has to be changed, will do if i need it later.

Thanks Terry - if KeepConn doesn't work, I know wat to do next ;)
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top