Solved: Wireless Intel 3945ABG on vaio ar-series not working!

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

germancho

Thread Starter
Joined
Nov 22, 2005
Messages
40
Hullo!

I accidentally switched off the wireless switch, and nothing I do since seems to work to turn it back on.

The simplest thing I usually try (this isn't the first time it happens) is disabling the connection in Network Connections and enabling it while I switch the switch on. That didn't work. Automatic Repair of the connection didn't work either.

My VAIO comes with a switcher.exe program to enable and disable bluetooth and wireless. The program seems to work normally, but the wireless (and the indicator led) won't turn on.

Then I go to Wireless Network Connection Properties, and then on the General tab I hit the Configure button and then to the General tab: the device usage says the device is enabled (it's not). Then I go to the Advanced tab and there is a drop down menu that says wireless OFF. I check the wireless ON option, OK but nothing happens!

All of the methods listed above have worked in the past.

So, parts of the computer seem to think Wireless is on when it's not. However, not all the programs agreee: the VAIO Wireless LAN Setup Utility says the device is turned off (duh). The network setup wizard also recognizes the wireless hardware as OFF.

I run XP btw.

What do I do? Heeelp!
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,429
Hold the Windows key and press R, then type devmgmt.msc

Please respond to all the following steps.

  1. Under Network adapters, please tell me all the devices listed.
  2. Are there any devices under Network adapters that have a red x displayed?
  3. Also, are there any devices anywhere in the Device Manager display with yellow ? or ! displayed?


Let's see this as well.

Hold the Windows key and press R, then type CMD to open a command prompt:

In the command prompt window that opens, type type the following command:

Note that there is a space before the /ALL, but there is NOT a space after the / in the following command.

IPCONFIG /ALL

Right click in the command window and choose Select All, then hit Enter.
Paste the results in a message here.

If you are on a machine with no network connection, use a floppy, USB disk, or a CD-RW disk to transfer a text file with the information to allow pasting it here.
 

germancho

Thread Starter
Joined
Nov 22, 2005
Messages
40
Hi John Will! Thanks for your response.

I checked the device manager and nothing shows x's or ?!'s all the devices (seem) to be working properly. However, the ipconfig /all shows this:

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Valued Customer>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : Bebop
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection 2:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connection
Physical Address. . . . . . . . . : 00-13-A9-27-B3-89

Ethernet adapter Wireless Network Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Intel(R) PRO/Wireless 3945ABG Network Connection
Physical Address. . . . . . . . . : 00-13-02-69-EE-43

C:\Documents and Settings\Valued Customer>

Peace,

G
 

TerryNet

Terry
Moderator
Joined
Mar 23, 2005
Messages
80,917
Try the wireless physical switch or key combination, which ever your laptop has.
 

germancho

Thread Starter
Joined
Nov 22, 2005
Messages
40
Thanks Terry, but that's the first of 10²² things I tried. I think the real solution is just as simple, but definitely much less evident than that.

That or my wireless system is fried.
 

joebloggit

Banned
Joined
Oct 4, 2008
Messages
190
i had this problem with my dell laptop(with bluetooth) i had to go into bios and configure...enabling the switch.....
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,429
Does the status of the wireless change when you turn it off using the wireless switch? I'd like to see an IPCONFIG /ALL with that switched off.
 

germancho

Thread Starter
Joined
Nov 22, 2005
Messages
40
Hi Joebloggit and JohnWill!

I tried going to the BIOS and ghanging stuff around, but I didn't find much room for change. Not one hardware related control.

The ipconfig results didn't change after I jiggled the switch around, it seems the switch is not physically working!
 

joebloggit

Banned
Joined
Oct 4, 2008
Messages
190
thats wierd?....i had all sorts of probs with bluetooth and it turned out the switch wasnt configured correctly in bios...(ie.configured to turn wireless on and off with bluetooth)..it should be in your bios somewhere tho as it is a peice of hardware??...my sympons were slightly diffrent as in the switch worked but only for wireless...
 

joebloggit

Banned
Joined
Oct 4, 2008
Messages
190
i just checked my bios..its has wireless in the main list...and if you open that all the settings for the switch are in there..but if your not even seeing wireless in there thats not helping you...what i will say tho,is that when my bluetooth played up(again didnt show in bios as if it didnt exist) the fix was to shut down the machine remove the battery,disconnect the bluetooth module and reconnect...then restarted and it showed in the bios....then i configured the switch....maybe worth giving that a shot???...(obviously with your wireless harware not bluetooth...lol..)
 

germancho

Thread Starter
Joined
Nov 22, 2005
Messages
40
It was the switch, after poking it around a lot it lit on, but it's a highly unstable setup... I'll still pop the switch open and check for problems.
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,429
Sounds like the switch is dying.

You can mark your own threads solved using the
button at the top of the first page of the thread in the upper left corner.
©
:)
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top