Solved: Word 2007 Mail Merge Unwanted Blank Line!

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Shadowfax27

Thread Starter
Joined
Oct 20, 2009
Messages
2
I have it set up to list an agency and then a recipient.

<name>
<address 1>
<address 2>
<city, state, zip>

<date>

<recipient name>
<address 1>
<address 2>
<city, state, zip>

In the first set it seems like it automatically set it as an address block even though it doesn't say it anywhere and if the address2 is blank it moves the city,state,zip up to fill in the gap. In the recipient address, if there is no address2, it leaves a blank line. Using the address block fix is problematic because it does not seem to want to allow me to choose the specific fields, it names them for me. Also, there are nine versions of the letter I arranged into excel fields to get around having to create multiple versions. I was going to just either put the info in the excel field or leave it blank, but it leaves blank lines on that too.

Is there a way to suppress the blank fields? I have seen some complicated sql language that supposedly will do it, but I don't understand what they're telling me to do.

Help!

~Shadowfax
 
Joined
Apr 30, 2007
Messages
255
For fields that might be blank, try conditionally adding that field versus a regular add. In your example, it would look something like this:

{Mergefield "Address 1"}{IF {Mergefield "Address 2"} <> "" "
{Mergefield "Address 2"}"}
 

Shadowfax27

Thread Starter
Joined
Oct 20, 2009
Messages
2
I tried all kinds of tricks like that last night, even going so far as to do what you did and distribute the quotes on two lines to show a line break if there was a field and not if the entry was blank. It didn't really help, it put the entries on the same line or omitted the rest of the entries following. Very strange. I'm sure there is a work around that would work utilizing that technique, but I didn't find it.

HOWEVER.. I did find a solution! If you hit the home tab and click on the pilcrow (the weird looking p thing that shows paragraphs and line breaks), it will show the paragraph ends and line breaks. In order to function properly each line containing an excel call function needs to end a paragraph. If you get the spacing you want by using shift/enter, you can turn on the pilcrow and copy and paste them to edit the code without messing up the design!

Oh, I was going to pm you and thank you for the response, but apparently I'm too new of a member. Thanks for the help! I hope my fix helps others as well. That is a tricky nasty little issue!
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top