Solved Some of my shortcuts on my desktop are white

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

linsjean

Thread Starter
Joined
Sep 6, 2006
Messages
368
I think this started when I swtiched from Firefox to Edge. I couldn't get used to edge, so I reinstalled firefox. I have some URL's saved to my desktop. I know they should be in my bookmarks, but they are there temporarily because they are reminding me that I need to take action on some things. Otherwise, I will need to write a list of what to do and what website to go to.

I right-clicked on one of them, went to properties, and it won't give me permission to change the icon, or maybe I couldn't find the FF icon. I do have a couple of them correctly colored icons, but maybe those are files instead of a short cut. The Xfinity one brings me to a website to review my entire chat with Xfinity. Bookmarks was exported when I decided to try Edge.

Yes, my default browser is Firefox now. I checked.

So, how do I get these shortcuts back to the fameous organge Firefox icon?
 

Attachments

Joined
Mar 2, 2019
Messages
823
Hello. If this is what I think it is then,
the procedure depends on shortcut file extension.

If you can't see shortcut file extension then here is how to enable this:
Press Windows key + R and type or copy paste bellow string and hit enter:
control.exe folders
in file explorer options click on "View" tab
then make sure "Hide extensions for known file types" is not checked

Now on your desktop check file extensions for these shortcuts.
If you still can't see the extension then the extension is *.url

Click on Start button and open Settings app
Click on Apps
Click on Default apps
Scroll down and click on "Set default apps by file type"
Now in that long list find the extension that those shortcuts use.
then if next to file extension there is + (plus) sign click on it and select Firefox browser or just internet browser or locate firefox.
If next to extension is something else but not firefox, set it to firefox.

That's it, this should show the icons,
however if extension type is *.url, shortcut icon may depend on contents of that file.
so you can try to recreate this shortcut.

If unsure what is the actual url, open the shortcut with notepad, and there is url you need, visit this url,
and make a new shortcut or bookmark
 

linsjean

Thread Starter
Joined
Sep 6, 2006
Messages
368
Hi,
I do believe I followed your directions. Except I saw htm with Firefox next to it, in the long list. Maybe I should go back and find URL instead of HTM, because what I did, did not work.

I also opened a shortcut and it does open in my firefox browser. I drug the URL to my desktop (after deleting the original one on my desktop) and it is white again.
 

Attachments

Joined
Mar 2, 2019
Messages
823
Hi,
I saw htm with Firefox next to it, in the long list. Maybe I should go back and find URL instead of HTM
According to second screenshot this is an *.url file.
So, yes you must set Firefox as default for *.url files in the list.

URL File format is described here:
http://www.lyberty.com/encyc/articles/tech/dot_url_format_-_an_unofficial_guide.html

Here is how to create *.url shortcut with firefox icon manually:
NOTE: these steps assume you have followed previous steps to
enable showing file extensions, and you have set firefox as default for *.url files!


Create a new text document on your desktop and open it.
copy and paste bellow code into that text file:
close the file and save.
select file and press F2 key to rename the file.
then rename it to:
techguy.url
for example if previous file name was:
NewTextDocument.txt
you replace all this with
techguy.url
replacing entry string, including txt extension!

That's it you now have a shortcut to this site with firefox icon.
If for some silly reason you still do not see an icon on that file, select it again,
press F2, rename to something else and hit enter.

Do the same for all your shortcuts which failed to show the icon, replacing URL string with the actual url from your bad shortcuts.

Note that *.url extension is not visible for security reasons.
However that doesn't mean it can't be shown by default if you want.
 
Last edited:
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top