SOS: Browsing Internet Keep having "Problem loading page"

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

bistenciao

Thread Starter
Joined
May 27, 2012
Messages
1
For the last few months, and lately progressively worse, whenever I get on my laptop to browse the web, it takes me a long time because I keep getting the error "Connection has timed out". I get this error no matter what browser I use. I am connecting to a home wireless network. The roommates are not having any issues. When mine times out, theirs is working fine. I tried connecting to the network with a usb and plugging in, and got the same errors. I can browse the web, but usually only for about a minute and then it won't work. I have to wait a few minutes and try again. I am about to try reloading windows and backed up all my files, but I don't want to have to do this if there is something I am missing. My laptop is an ASUS U52F, using Windows 7 64 bit. Please help!
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top