1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

sound driver? intel d945ppr

Discussion in 'Hardware' started by nikkiname, May 3, 2011.

Thread Status:
Not open for further replies.
Advertisement
  1. nikkiname

    nikkiname Thread Starter

    Joined:
    May 3, 2011
    Messages:
    4
    please help me! i just finished fixing a sony vgc-rb60g with a intel d945ppr/d945gpr mother board. i installed windows vista home basic sp2. the only problem is i cant find a sound driver for it, i've searched every where and nothing works. please some one help me!
     
  2. flavallee

    flavallee Frank Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    63,654
    An Intel D945 model motherboard is going to have a 945 chipset and 945 graphics.

    The Intel site doesn't list a D945 model that ends in PPR or GPR. Are you positive about the model number?

    ---------------------------------------------------------------

    Here is the support site for the Sony VAIO VGC-RB60G.

    The sound device is a Sigmatel High Definition Audio, and it does have a driver(6.10.0.5290) for Windows Vista.

    ---------------------------------------------------------------
     
  3. nikkiname

    nikkiname Thread Starter

    Joined:
    May 3, 2011
    Messages:
    4
    i checked the board and it says its a d945ppr/d945gpr, i tried installing a 945g and 945p chipset but it really didn't help. i tried installing Sigmatel High Definition Audio driver it says it wasn't intended for my model. device manager says the Internal High Definition Audio Bus not configured correctly and has no driver.
     
  4. flavallee

    flavallee Frank Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    63,654
    Go into Control Panel - Device Manager.

    What's currently listed in

    Other Devices (if present)

    Sound Video And Game Controllers ?

    -------------------------------------------------------------
     
  5. nikkiname

    nikkiname Thread Starter

    Joined:
    May 3, 2011
    Messages:
    4
    just that high definition audio bus. windows keeps trying to find drivers for it, but they don't work ether.
     
  6. flavallee

    flavallee Frank Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    63,654
    The Device Manager lists all the other devices and shows them as working properly?

    I gave you the support site for that computer. If the audio driver listed there for Vista doesn't work, I don't know what else to tell you, other than to install a sound card to replace the integrated audio.

    ------------------------------------------------------------------
     
  7. win2kpro

    win2kpro

    Joined:
    Jul 19, 2005
    Messages:
    11,669
    Since the machine originally came with XP MCE I would try the XP MCE original Sigma Tel High Definition Audio Device Driver 5.10.4717.0 and if it loads then try to load the Sigma Tel High Definition Audio Device Driver Update 6.10.0.5290. Since the 6.10.0.5290 file is an update the high definition audio bus driver may be a file included in driver 5.10.4717.0
     
  8. nikkiname

    nikkiname Thread Starter

    Joined:
    May 3, 2011
    Messages:
    4
    I think I'm just going to install another sound card, but thanks any ways guys.
     
  9. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/994824