1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

spoolsv.exe peaking CPU

Discussion in 'Windows XP' started by pianoman121, Jan 9, 2003.

Thread Status:
Not open for further replies.
Advertisement
  1. pianoman121

    pianoman121 Thread Starter

    Joined:
    Jan 9, 2003
    Messages:
    2
    spool service is peaking the CPU every time I print causing the printer to pause during printing and resulting in very slow printouts. It will drop (CPU usage) every few seconds and allow the printer to continue then jump back up to 100%. I've tried printing directly to the printer, parallel, USB, different printer, reinstalling the printer, moving the spool folder, kicking it. nothing.
    I am running an Epson photo 820 (USB), with WinXP, 700 CPU, 350MB ram, 18 Gig HD (15 avail.)
    I've updated SP1, no change.
    I'm using mainly graphics software (Gerber Omega, Corel Draw) but even simple vectored art prints slow.
    I also have a thermal printer hooked up to LPT1 - tried disabling it, no change.
    ???
     
  2. $teve

    $teve

    Joined:
    Oct 9, 2001
    Messages:
    9,396
    Spoolsv.exe = CPU hogPossible Cause:
    could be:
    Print job still in que
    Suggested Fix:
    Cancel print job
    Step by Step:
    1. Go to Settings>Control Panel>Printers
    2. Locate pending print que under the documents column.
    3. Double click on printer to pull up spool que.
    4. Right click on first job and select cancel.
    Result:
    This should cancel the hung print job and free up the CPU.
    Typically this is the result of an incompatibility between the print job source and the printer driver. If you record the source of the job and the desired printer, you may be able to find out from the driver distributer where the conflict is originating-- it might be as simple as a font!!

    hood luck;)
     
  3. pianoman121

    pianoman121 Thread Starter

    Joined:
    Jan 9, 2003
    Messages:
    2
    there's no pending jobs in the queue. It happens with every print job.
     
  4. cj_white

    cj_white

    Joined:
    Oct 28, 2001
    Messages:
    333
    spooler service may be corrupt. find the spoolss.exe and he spoolss.dll. back them up and then delete the original. before you do this make sure you have the backups in the I386 dir. they should look like this. spoolss.ex_ & spoolss.dl_. if you have those then delete the original and copy and rename the ones fromthe I386 dir.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/112294

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice