Strange FPS drops in games

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

bigfatsquid22

Thread Starter
Joined
Jan 6, 2012
Messages
1
This started awhile ago pretty randomly. I play WoW, TF2, CSS, SWTOR, and LoL. I experiance the same strange drop in FPS into single digits for about 5-10 seconds, then right back up to 60-70 FPS. I have tried everything that I know and am still getting the strange drop in FPS.

I have reinstalled Win7, updated all drivers, etc. I have ran AV software, and Malwarebytes, and got nothing. When I run my games i run Gamebooster, still nothing. Cleaned my cache, cookies, defragged, everything and still I get these nasty FPS drops.

I'm running

64bit Win7
Intel Core Duo2 3GHz
3GB RAM
Geforce 8600 GT

So yeah, if anyone out there could help I would much appreciate it. All I wanna do is play my games without this annoying FPS drop. Thanks All.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top