Strange monitor problems ...

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

swarr

Thread Starter
Joined
Nov 29, 2001
Messages
1
I have a 6 month old iiyama 17" monitor which has just
started to randomly switch into a blank-screen mode
(you can hear the monitor "mode-click") - possibly a
power saving mode? The power light stays on, but the
image only comes back if you switch off and on again.

As the monitor warms up, the screen blanks more
and more frequently (seconds), and even blanks
during the machine BIOS boot stage (so it isn't
windows). I have tried it with a second video card,
and even a second machine, and its definitely the
monitor...

Now obviously the monitor is still under guarentee, but
the previous monitor I had (different brand) did exactly
the same thing after about 4 years. Is this horrible
coincidence, or is there something more sinister that
might be affecting the monitor?
 
Joined
Jan 30, 2001
Messages
3,992
Hi swarr

Yes it sounds like the monitor is going bad. You might want to get a surge supressor for your AC line if you don't have one. But you probably just got a bad monitor. At least its still under warranty! :)
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top