Surface Pro 6 won't charge when plugged in, no indicator lig

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Ariluvsatari

Thread Starter
Joined
Jul 30, 2019
Messages
1
I bought a Surface Pro 6 a couple of months ago from Costco. Everything was great until the charger wouldn't work. To be more specific, it will be plugged in and the indicator light will not turn on and or charge at all. Sometimes it will charge, but it will not charge for long. I've tried everything including: flipping the charger over multiple times, switching outlets, using an extension cord, and unplugging and plugging in again. The first couple months of using the Surface Pro 6 was amazing- then the problem started. I even called Microsoft and they sent me a NEW charger, which worked for a month. I currently cannot charge my computer, and I'm upset because I paid a very large amount of money to buy a reliable computer/tablet, and I'd really like some help. Thank you.
 

texasbullet

Ramon
Joined
Jun 11, 2014
Messages
2,719
If still under warranty take it back to Costco for replacement or repair or check your computers manual for warranty repair info.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top