svchost.exe

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

peakhead12

Thread Starter
Joined
Feb 4, 2003
Messages
3
For awhile now i have been having this problem. Whenever i run my pc (it doens't always happen at startup but it happens eventually) programs refuse to run. By programs i mean any and all programs that i click on. After trying some other things to fix the problem, i tried running taskmanager after startup and ending some processes one by one to see if that would help. This is what i came up with. Any time i started having the problem, i would end one of the svchost.exe (svchost not svhost, i dont' have a virus) processes, and then immediately all of the programs that i had clicked on previously would all open at once and i would be able to open any new programs that i wanted to. However, all of the services that the process was handling were disabled like my theme, and all sound through my sound card. Here is a list of the services inside the svchost process that i end to solve the problem(i always end the same one):
-----------------
helpsvc HidServ lanmanserver lanmanworkstation Netman Nla RasMan seclogon SENS SharedAccess ShellHWDetection srservice TapiSrv TermService Themes TrkWks uploadmgr winmgmt
-----------------
Also i would like to add that before i started having the problem msn messenger would act up and freeze, so i uninstalled it and removed all the registry entries, but the problem persisted. Also, messenger used to be in the above list of services run by the process until i uninstalled it.


Any ideas on what is wrong? I'm stumped :(
or what i can do?


Here is a list of all of the processes i have running:

C:\WINDOWS\System32\smss.exe
C:\WINDOWS\system32\winlogon.exe
C:\WINDOWS\system32\services.exe
C:\WINDOWS\system32\lsass.exe
C:\WINDOWS\system32\svchost.exe
C:\WINDOWS\system32\spoolsv.exe
C:\WINDOWS\Explorer.EXE
C:\windows\system\hpsysdrv.exe
C:\Program Files\Logitech\iTouch\iTouch.exe
C:\WINDOWS\System32\ctfmon.exe
C:\WINDOWS\System32\PackethSvc.exe
C:\WINDOWS\System32\nvsvc32.exe
C:\WINDOWS\wanmpsvc.exe
C:\WINDOWS\System32\taskmgr.exe
C:\Program Files\Internet Explorer\iexplore.exe
C:\WINDOWS\System32\svchost.exe
C:\Program Files\WinRAR\WinRAR.exe
C:\DOCUME~1\Owner\LOCALS~1\Temp\Rar$EX00.718\StartupList.exe
 
Joined
Apr 12, 2002
Messages
111
From what I read it seems you're running a server. Are you using a WAN based internet service like AOL broadband? I am also unfamiliar with WinRAR. Do you know what program this is associated with? The rest seems normal to me.
 
Joined
Apr 12, 2002
Messages
111
Backing up, I re-read the post. Ignore the server statement. I think I need to go back to english class 101. Sorry :(
 
Joined
Sep 16, 2002
Messages
1,157
I think you've inadvertently deleted the wrong registry keys.

svchost is messenger
MSN Messenger is MSN Messenger
 

peakhead12

Thread Starter
Joined
Feb 4, 2003
Messages
3
I don't follow what you are saying...i was having the problem before i removed any keys...uninstallling messenger and removing the keys it left behind did nothing at all.
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,429
SVCHOST is NOT messenger and you do NOT want to tinker with it! Here's a better explanation that I'm willing to type. :) What is SVCHOST
 

peakhead12

Thread Starter
Joined
Feb 4, 2003
Messages
3
oh, i know what svchost is and what i does, i understand that it is not messenger, but messenger is one (among many)of the services that svchost handles and messenger was the program that was constantly freezing so i decided to uninstall it. The only relevance it has to my problem is that the svchost process that i was ending was handling the messenger service.

I guess the question that i'm trying to ask is why would that instance of svchost be preventing me from running programs?...and is it a coincidence that messenger was constantly freezing and that it was one of the services being run by svchost?

Or better yet do you know how svchost could be involved in this problem? I don't want to mess with svchost, but i need to fix the problem.
 
Joined
Sep 16, 2002
Messages
1,157
Yes, sorry for the confusion . . .
what I meant was svchost is handling the messenger service (netbios, net send), but this messenger service is not MSN Messenger, they are two entirely different things. So, what I was suggesting was that maybe you've deleted some registry keys relating to messenger, not MSN Messenger.

Here's some points of reference:
http://support.microsoft.com/default.aspx?scid=KB;EN-US;Q330904
http://www.jmu.edu/computing/security/info/winmsg.shtml
http://www.its.caltech.edu/its/security/users/windows_messenger.shtml

But as you said, maybe we're on the wrong path here, and the problem is being caused by something else entirely.

I think I must've misinterpreted your original post where you said:
"Also i would like to add that before i started having the problem msn messenger would act up and freeze, so i uninstalled it and removed all the registry entries"
 

yyz

Joined
Aug 12, 2003
Messages
3
Hi people!

I stumbled in here for help with a problem I have been having recently.

I have been getting a window that states something to the effect that "svchost.exe" has caused an error, and an error log will be completed.

This pops up all of the time! Now, my computer wont allow me to do simple tasks.

  • Cut and paste
  • Copy and paste
  • Click on liks while in threads such as these
  • Add smilies to posts

I know it's piddly stuff, but it makes me angry, and I wonder about deeper problems as this this burries itself in my system.

I even tried reloading my Windows 2000 TWICE, and that damned thing keeps popping up!

All the help that I have been offered on other sites has come up bust.

PLEASE.........Someone rescue my sorry arse!
 

RGT

Joined
Aug 12, 2003
Messages
1
I,m having the exact same prop. as YYZ. SVCHOST.EXE. Need help too...............
 

yyz

Joined
Aug 12, 2003
Messages
3
I can't open programs, either.

My Norton AV no longer loads, I can't open any site from within another site...........I am ready to quit!
 
Joined
Aug 12, 2003
Messages
8
I thing its a worm, if you don't have a firewall INSTALL it as soon as possible I have the same problem yesterday.

Try to disconnect the netwrok and restart if svchost don't get crazy, you've found the problem.

TO SOLVE IT
1)Install alarmZome, it prevents the attacks.
2)If you have Servicepack 2 try to install Windows2000-KB823980-x86-ESN.exe you can find it in the Microsoft page.

Good Luck!!!!
 
Joined
Aug 12, 2003
Messages
11
I got the problem, a lot of people have it too, its a worm virus W32.Blaster. Its a virus that I'm trying to tackle at the moment, I've removed it but SCVHOST still crashes. I'm running the scan for the 2nd time now to see if it has respawned since last reboot. its very annoying because I don't have Servicepack 2 and my 56k modem is gonna struggle to download it -.-
 
Joined
Jul 13, 2002
Messages
122
Just stumbling through this room but ya'll need to go look at the "last thread"

(Shutdown of computer, caused by RPC - if this happens to you, read this..)

It is all about the MSBlast worm that is infecting XP, 2000, NT......
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top