System freezes incessantly

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

nmithani1

Thread Starter
Joined
Apr 5, 2006
Messages
161
Everyday, especially, whenever I use a download manager, Vista starts freezing and un-freezing with the mouse freezing in its place and shooting across the screen when Vista un-freezes. The download speed falls dramatically (~650 KB/s to ~250 KB/s) every few seconds coinciding with the freezing and un-freezing.

It's not the fault of the download managers, they're not out-worldly, Vista incompatible softwares; I've also tried multiple download managers, Flashget 1.73 and Internet Download Manager (latest) are the ones I am using presently.

Whenever I use these download managers, at the most a browser and iTunes are running, apart from the standard background processes.

Considering my system specs, this is mind-boggling. Secondly, this skipping and freezing never occurs on my brother's laptop in using these softwares even though its specs are half of what mine are, and we both use Vista Ultimate.

My system specs:

Asus P5VDC-X
Pentium D 3.40 GHz
2 GB DDR2 RAM
nVidia 7900 GT 256 MB
HDD 1: 160 GB Western Digital (IDE)
HDD 2: 250 GB Seagate (SATA2)
Windows Vista Ultimate (32-bit)
 
Joined
Jul 1, 2007
Messages
22
i purchased a gateway laptop a few weeks ago. it freezes up so much. i think its the HD .But i bet its VISTA.mines freeze more online or media player is going. i reduced to 16 bit resolution and tons more stuff.Office Depot is hating on me.If i cant get XP PRO/home . i will toss my 900$laptop into the river as a disgust to MICROSOFT!
 

nmithani1

Thread Starter
Joined
Apr 5, 2006
Messages
161
I too would ditch my Windows Vista PC for an iMac in a heartbeat if I didn't dislike the iMac's display.
 
Joined
Oct 5, 2007
Messages
3
Think it's a VISTA thing instead of a laptop/PC manufacturer thing. I have 2GB memory and the memory shows about 51% at all times. Something is wrong, but haven't narrowed down what it is. Hope someone that has used VISTA home premium longer than I have has some ideas. I will not throw the laptop in the river as a show of disgust to MS, that would hurt me more than them. MIGHT switch to UBANTU or something similar however.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top