1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved System-freezing non-system disc

Discussion in 'Hardware' started by Apolllo, Sep 12, 2017.

Advertisement
  1. Apolllo

    Apolllo Thread Starter

    Joined:
    Sep 12, 2017
    Messages:
    4
    Hi guys.

    CPU: Intel I5-2400
    Mobo: Asus P8H67-M Pro
    RAM: 16G DDR3 1333
    Discs: 256Gb SSD (= system), 1T Seagate, 2T Seagate + the problem disc (2T Seagate)
    OS: Windows 7

    I recently installed a brand new 2T hard drive. (It's not the system drive.) Later, I noticed that there was a small partition on it, and decided to merge it. Somehow, something went wrong. The drive seemed to have somehow got corrupted. So I then decided to run a file system check and repair (with Partition Wizard). Because it was literally taking hours and I had something to do, I finally forced my computer to shut down, intending to try again later.

    When I rebooted, the system wouldn't reboot. It would just freeze at the BIOS splash screen. This is the current state of affairs.

    If I disconnect the drive, the system boots up fine.

    I found out that I could successfully connect the drive using a USB to SATA cable. So I used that to full-format the drive. Now, it works just fine, but only through the USB port. If it's connected back to the SATA port on the motherboard, it still won't allow the system to boot up . Everything freezes at the BIOS splash screen. (I swapped some other discs into that SATA port. The port is working fine.)

    One thing that I noticed is that my other (3) discs are all MBR while this new disc is GPT. I don't remember if it was originally GPT (before I tried to merge that small partition). I'm not sure if this could be related to the problem.

    Any advice would be greatly appreciated.
     
  2. Sponsor

  3. Macboatmaster

    Macboatmaster Trusted Advisor

    Joined:
    Jan 14, 2010
    Messages:
    18,687
    To which SATA port is the 2TB Seagate connected
    Please see page 1-7 of your motherboard manual
    There are 6 SATA ports
    the lower two towards the edge of the board are number 1 and 2 and are SATA 6GB
    the upper 4 are numbered 1- 4 and are SATA 3GB
    If you do not have your manual here is the download
    http://dlcdnet.asus.com/pub/ASUS/mb/LGA1155/P8H67-M_PRO/E6149_P8H67_M_PRO.zip

    I suspect that the boot priority is to the port that you are connecting that new drive to and the system although the board has UEFI firmware is installed Legacy on MBR
    Legacy systems cannot boot from a GPT partitioned drive, as they do not have an MBR - master boot record
    When you try another drive in that SATA port I think the system then realises it cannot boot from that drive so the firmware hands control to the next drive eg the ITB Seagate
    When the new drive is connected I think the system then sees that drive and attempts to boot from it
    The answer is to check the boot priority in the firmware and change the priority to move the SATA port with the 1TB Seagate to the top of the boot priority list or at least above the sata port to which the 2TB Deagte is connected

    If windows 7 is 32 bit then it is most certainly installed MBR as it cannot be installed UEFI GPT
    64 bit can be installed UEFI on a GPT disc

    Here is how to make certain what firmware and setup you are using
    see my screenshot please
    Untitled.png

    There is a slight chance that the problem is not as above but what you have done
    It is NOT that the drive is GPT
    That would still work on a MBR system but not of course a boot drive
    If that is the problem when you reply we will solve that cause
     
    Last edited: Sep 12, 2017
  4. Apolllo

    Apolllo Thread Starter

    Joined:
    Sep 12, 2017
    Messages:
    4
    Hi Macboatmaster.

    Thanks a lot for your amazing reply. There's quite a lot for me to take in there.

    First, here's some information that I hope clears matters up a little:

    1) The Windows 7 OS is 64 bit.
    2) The problem (i.e. new) disc was connected to the SATA 3GB port 1.
    3) The m'board is using Legacy MBR.
    4) All the discs except the new (problem) disc were MBR. (Since then, I converted one old, empty disc to GPT to see if it would cause similar problems. It didn't.)

    Here's another odd development.

    I moved my system disc (SSD) to the SATA6GB Port 1. No problems. (The problem disc was NOT connected, of course.)

    I then moved the problem (new, GPT) disc to the SATA6GB port 2.

    I disconnected all the other discs (so that all that was left was the system disc and the problem disc.)

    On boot up, it would go into BIOS - after a long pause. It would then get past that step and go to the Windows splash screen, where it would get stuck for several minutes. It would then go to the Windows desktop, but would be stuck (e.g. no cursor movement and the revolving timer symbol) for several more minutes before the system was usable. BUT ... there was no trace of the (new, problem) disc anywhere - not in Device Manager, Disk Management or anywhere else.

    I then uninstalled all the ATA drivers, shut down, connected up all the discs (system, 2 functional and one problematic) and restarted. The machine booted up - very, very, very slowly. And there it was - the problem disc was online and functioning again!

    I booted up one more time. Not a peep. I froze on the BIOS splash screen again. Back to square one.

    I disconnected the problem disc and left all the other (3) discs plugged in. It booted up like a rocket.
     
    Last edited: Sep 13, 2017
  5. Macboatmaster

    Macboatmaster Trusted Advisor

    Joined:
    Jan 14, 2010
    Messages:
    18,687
    connect the disc usb
    when you have that
    open a cmd prompt with admin rights
    type
    diskpart
    press enter
    then type
    list disk

    identify the disc the 2TB you have connected usb
    ensure beyond doubt that you have the disc identified
    when you have - lets presume it is disc 2 letters are a windows allocation in diskpart they are numbered as in Disk Management on Windows

    when you have it identified type
    select disk and the number
    eg
    select disk 2
    the reply will be
    disk 2 is now the selected disc
    type
    clean
    when you have that and please remember there is no second chance on diskpart - there is no warning
    then with disk 2 still the selected disk
    type
    convert mbr

    Here are the cmds
    https://technet.microsoft.com/en-us/library/cc766465(v=ws.10).aspx

    you may if you need ensure you have the correct disk before proceeding with clean by using the cmd shown
    detail disk
    when you have already typed select disk ?

    However I presume with only the two connected one internally and one externally you will not need that cmd

    AGAIN ensure you have the right one - NO SECOND CHANCE on diskpart
     
  6. Apolllo

    Apolllo Thread Starter

    Joined:
    Sep 12, 2017
    Messages:
    4
    Done ... and working like a charm!

    Thanks so, so much for your help.

    Just curious ... do you think there's any value at all in changing to UEFI, or should I just leave things be, now that I'm finally back in business?
     
  7. Macboatmaster

    Macboatmaster Trusted Advisor

    Joined:
    Jan 14, 2010
    Messages:
    18,687
    With respect and I mean that most genuinely I do not think you understand what is involved
    Your motherboard has UEFI firmware
    That enables you to use the additional benefits of GPT partitioned system drives
    Larger - greater capacity hard/SSD drives
    and to some extent offers greater security against malware at boot

    https://en.wikipedia.org/wiki/GUID_Partition_Table

    However you cannot now change from the legacy MBR of the windows installation to the UEFI - Unified Extensible firmware interface
    https://www.bitfeed.co/page/uefi-what-it-is-and-what-you-need-to-know

    without a lot of work, basically you are reinstalling windows - and risk on your windows 7 installation and to some extent it is hardly worth the effort as some benefits of UEFI were part of the Windows 8.1 and 10 working together with the uefi firmware

    That said of course 7 goes end of life January 2020 and that is not really so far away -
    https://support.microsoft.com/en-gb/help/13853/windows-lifecycle-fact-sheet

    I would leave it as is and then if you decide you cannot stay with 7 that will then have NO security updates, NO future updates for system improvement etc
    Then if you do decide to change to 10 I would certainly go UEFI
     
  8. Apolllo

    Apolllo Thread Starter

    Joined:
    Sep 12, 2017
    Messages:
    4
    Yes, I'd agree that I don't understand what's involved!

    Many, many thanks for your help with this problem!
     
    Last edited: Sep 13, 2017
  9. Macboatmaster

    Macboatmaster Trusted Advisor

    Joined:
    Jan 14, 2010
    Messages:
    18,687
    Thanks again for your kind remarks
    Anytime you wish help - we are here for you
     
  10. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...

Short URL to this thread: https://techguy.org/1196250