System/Hardware/Windows Performance Issues

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

unknowns

Thread Starter
Joined
Jul 24, 2018
Messages
3
Hi,

I recently put together a new on-budget system, running on windows 10 (Installed from USB drive):

AMD Ryzen 3 1200 (NZXT Kraken x52 cooling)
Nvidia GeFroce GTX 1050 Ti
MSI B350M PRO-VDH
Kingston x Fury DDR4 8 GB
WD Blue HDD 1TB
Seasonic Focus Gold+ 650w

Problem being, before installing new HDD, I was using the old one from previous system and everything was fine in terms of perfomance until I ran into problems with that HDD and windows, resulting in clean installing new (listed above) HDD and windows.

After completing clean install, I noticed that the system boot speed was a lot slower compared to first boot with old drive. Gaming performance also went down by a ton and the games optimized themselves for medium settings instead of previous very high (LoL).

I checked if I had all the drivers installed/updated etc. No change.

Any advice on how to troubleshoot/solve the problem would be much appreciated.
 
Last edited:
Joined
Mar 30, 2014
Messages
4,451
A gaming setup should be running a SSD (solid state drive) instead of an ancient mechanical drive with platters that spin at a snail's pace speed of 5,400 RPM.

Just saying ...
 

unknowns

Thread Starter
Joined
Jul 24, 2018
Messages
3
A gaming setup should be running a SSD (solid state drive) instead of an ancient mechanical drive with platters that spin at a snail's pace speed of 5,400 RPM.

Just saying ...
I'm well aware and am saving up money for a good one (they expensive) but that's not the issue as I had stellar experience with the old one (5-6 years old drive), just everything went down hill after installing new windows + drive.
 

unknowns

Thread Starter
Joined
Jul 24, 2018
Messages
3
Was the old hard drive spinning at 7,200 RPM ... which is 33% faster than 5,400 RPM?
Nah, it was just as fast and overall loading speed (folder loading, desktop use) isn't that much slower but I can notice it's a tad slower.

The main issue that is the most noticeable for me is hard fps drops and literal lag and the fact that the game no longer optimizes itself for highest settings but goes straight for medium and even if I set it to lowest it's basically same.
 
Joined
Mar 30, 2014
Messages
4,451
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top