New System running verry bad and sluish

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

slcmlc

Thread Starter
Joined
Jul 15, 2014
Messages
47
Tech Support Guy System Info Utility version 1.0.0.4
OS Version: Microsoft Windows 10 Home, 64 bit
Processor: Intel(R) Core(TM) i3-4010U CPU @ 1.70GHz, Intel64 Family 6 Model 69 Stepping 1
Processor Count: 4
RAM: 4027 Mb
Graphics Card: Intel(R) HD Graphics Family, 1024 Mb
Hard Drives: C: 909 GB (373 GB Free); D: 20 GB (2 GB Free);
Motherboard: Hewlett-Packard, 2141
Antivirus: Avast Antivirus, Enabled and Updated

Computer running very bad.
icons taking a very long time to load
crom seems when i am trying tyo scrool up or down page it will jump all the way to bottom and when i try to scrool back up will move a little bit and then jump all the way back up to top
i have ran avest and house call says no virus found not convinced
 

flavallee

Frank
Trusted Advisor
Joined
May 12, 2002
Messages
82,100
Get rid of Avast Antivirus and stick with Windows 10's built-in Windows Defender Security Center.

The C: drive is almost 60% full, so it's my guess there are a lot of installed apps and/or a lot of personal data.
It's also my guess there are a lot of running processes.

Your HP(unknown model name and model number and serial number) also has a weak processor and only 4 GB of RAM.

Capture.JPG

---------------------------------------------------------------
 

slcmlc

Thread Starter
Joined
Jul 15, 2014
Messages
47
Tech Support Guy System Info Utility version 1.0.0.4
OS Version: Microsoft Windows 10 Home, 64 bit
Processor: Intel(R) Core(TM) i3-4010U CPU @ 1.70GHz, Intel64 Family 6 Model 69 Stepping 1
Processor Count: 4
RAM: 4027 Mb
Graphics Card: Intel(R) HD Graphics Family, 1024 Mb
Hard Drives: C: 909 GB (760 GB Free); D: 20 GB (2 GB Free);
Motherboard: Hewlett-Packard, 2141
Antivirus: Windows Defender, Enabled and Updated

I cleaned off most of my files

when i'm browsing with chrome
and scrolling up or down it will jump all the way to the bottom of page, and when i try to scroll back up it will jump all the way back to top of page , i also reset browser to restore defaults still does same

thanks
 

flavallee

Frank
Trusted Advisor
Joined
May 12, 2002
Messages
82,100
The Google Chrome browser is known to be a memory hog.
Try using Windows 10's built-in Internet Explorer browser and see if that helps.

----------------------------------------------------------------
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top