1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Taskbar hangs/freezes in Windows XP Pro

Discussion in 'Windows XP' started by haloflaminlead, Mar 12, 2007.

Thread Status:
Not open for further replies.
  1. haloflaminlead

    haloflaminlead Thread Starter

    Mar 12, 2007
    Hello TechGuy forums,

    I am a very knowlegeable computer user, as a matter of fact I work as a computer repair technician, but I have encountered a problem that I cannot fix. And what do you know, it happened to my computer instead of a customers. I will update this post later today and include a HiJackThis log, since I am not home right now.

    Here are my comp specs: AMD 64 3400 2.0 ghz, Gigabyte K8NSC-939 motherboard with nForce chipset, Windows XP Pro w/SP2, 2 512mb (total 1 gig) Corsair DDR PC3200 ram dual channel, GeForce 5900 FX XT AGP video card, 2 ATA hard drives-1 250 gig 1 300 gig, Samsung DVDR/CDR drive, Logitech MX wireless laser mouse. Using onboard sound and NIC. Nothing is overclocked.

    The problem first started when I decided to try a new video card. The card I had in the computer and the new card both use the same nVidia driver (which is updated to the latest version), so I figured I could shutdown, take the card out, and put the new one in without having to mess with the drivers. It worked fine but I found I had better performance with my older card, so I put that one back in. I had some problems getting it to work again--when Windows would try to start the system would reboot. I eventually booted into safe mode and switched diagnostic startup on. This enabled me to bootup normally. When I tried using add/remove programs and nVidias uninstaller, the taskbar would freeze and the uninstall program would freeze. I could still move my mouse and see the desktop, but the taskbar was completely frozen. I ended the program, but it took a long while to get to task manager. I finally bought a 10 dollar program called nVidia driver cleaner which successfully uninstalled the drivers. I then reinstalled the drivers and figured everything would back to normal. Boy was I wrong.

    I have a problem now with the taskbar constantly freezing. At first I noticed the behavior when launching Warcraft 3. It would bring up the window that says launching and would act like it was going to maximize Warcraft, but then the taskbar and desktop would freeze. I could still see and move the mouse, and hear sound. When I press ctrl-alt-del, it brings up the little green icon in the system tray, but the taskbar remains frozen and the task manager does not come up on the desktop. When I do it again, it will bring up another one and show the task manager on the desktop, but I cannot click it. During this time, alt-tab does not respond. When I ctrl-alt-del a third time it brings up another one, and Windows finally decides to catch up with itself. Then Warcraft III maximizes and runs perfectly fine. Sometimes if I press ctrl-alt-del without long pauses in between, the computer will just freeze up and never come back. I usually wait a minute between ctrl-alt-dels. First I tried reinstalling Warcraft but experienced the same problems. I thought it could be the CD-rom driver, so I reinstalled that. Same problem. I thought it might be a scratched CD, so I tried a new one and a CD image. Same problem. I then ran Trend Micro online Anti-Spyware scan and Avast Anti-Virus and checked the start up. I did everything I possibly could to find spyware and viruses. Found some stuff but still same problem. I decided to run chkdsk, which found some errors, and defrag my computer. Same problem. I then tried reinstalling my nVidia nForce chipset drivers and checking for registry errors/issues with CC Cleaner. It found some issues but still same problem. Around this time I began to notice this taskbar behavior didn't just happen with Warcraft 3. It seems semi-random, but a lot of times it happens when launching a program, or when doing many things at once. For example I will launch this P2P program called Soulseek and it will have the same kind of taskbar behavior. This is not an infrequent problem. It happens everytime I use the computer. Windows responds fine but as soon as I launch a program or do multiple things at once, it seems like I am risking encountering this problem. I became very fed up and yesterday I repaired my Windows installation, installed SP2 and all updates, and reinstalled all drivers. I was positive this would fix the problem. MUCH to my dismay I encountered this exact same problem, which is incredibly frustrating. I am saving formatting/reinstalling as a last resort, since I have a ridiculous amount of files and programs.

    I think I may have a device or hardware problem but I am stumped, since it was all good before I swapped cards. Maybe something got damaged on the motherboard, but since Windows generally runs fine I have a hard time believing that's the issue. I've tried reseatting my RAM, CPU and graphics card but nothing has changed. I've reset all BIOS settings to default and nothing has changed. My BIOS has the latest update and my CD-rom has the latest firmware. I ran DXDiag and it found no problems. Other games, like Counter-Strike Source, run fine without launching problems.

    I've found several links with similar problems, and have not tried any of the fixes yet. I figured I would post them here:

    I have frequently found proposed solutions of this problem related to disabling services like BIT (background intelligent transfer) and something called SDP (that is related to UPNP). I have not tried them yet but for some reason I think they are not the issue, since things were working fine before. Before I repaired Windows, I had my services streamlined (unneeded ones shut off), which has been recommended as a solution to this problem, but I know it can't be since I had this problem before I repaired Windows (when the services were still streamlined). One of the last things I can remember changing on my computer before this all happened was uninstalling System Mechanic 6, which may have undone some startup/service tweaks, but I don't think that could be related because I've repaired my Windows installation since then.

    Any advise or suggestions would be greatly appreciated. If you need some more information feel free to ask.

  2. Sponsor

  3. ozrom1e


    May 15, 2006
  4. phonix932


    May 23, 2007
    stop the process spoolsv.exe. It worked with a similar problem on my computer
  5. oshwyn5


    May 23, 2007
    Have you tried creating a new user account and seeing if the problem is present there?
    It almost sounds like by using those automated cleaners you have damaged one of your registry hives.
    Of course, worst case scenario is you do a repair install and then reinstall anything that does not work.
  6. zooter


    Apr 30, 2008
    For what its worth, i had the same problem...

    memtest showed no errors....ruled out hardware issues as Ubuntu was working fine (dual boot)

    Tried every thing and finally after doing a fresh install of XP SP2, let Windows Update download and run...it updated a whole bunch of files (some 73 updates) and now my system is fine...no hangs for the past 2 weeks....

    could be a video driver that could be the culprit and was probably locking up with my nVidia onboard controller...

    I have been a little careful and not installed much software than is essential, but this seems not related to any particular software as the problem hapened right after a fresh install and after installing my video card drivers from the Nvidia cd (this could be the culprit too)
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/551140