This site can't be reached

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Corali

Thread Starter
Joined
Jan 10, 2019
Messages
11
Hey guys,

we have a problem logging into our wiki website (local server)
when we try to reach our wiki website we all get

"This site can’t be reached
xxxx refused to connect."



Now, this server is running on a local machine.
I have the login details for this machine and it is on right now.
I tried the different solutions on google/ youtube, nothing works.
In any case, this error occurs to all of us so I guess all of these local solutions wouldn't help anyway. I assume this is something to do with the server itself.
What should I check or do? I am logged in to the machine as an admin.
I'd appreciate any help.

BTW, I am new to all of it so I don't know much about network/server errors. Apologies for that.

Coral
 

Corali

Thread Starter
Joined
Jan 10, 2019
Messages
11
I also checked if the server is listening to the port( in this case 5000) by writing netstat -a -b but it doesnt, all of a sudden. How do I fix this?
 

DaveA

Trusted Advisor
Spam Fighter
Joined
Nov 16, 1999
Messages
16,562
First Name
David
How are you trying to login?
Are you using a browser, if so which one?
Have you tried using a different one?
 
Joined
Sep 21, 2007
Messages
11,985
I assume you are using Apache web server. If so, then do this :


Open httpd.conf file in your text editor. Find this line:

Listen 80

and change it

Listen 5000

After change, save it and restart apache.
 

Corali

Thread Starter
Joined
Jan 10, 2019
Messages
11
I assume you are using Apache web server. If so, then do this :


Open httpd.conf file in your text editor. Find this line:

Listen 80

and change it

Listen 5000

After change, save it and restart apache.
Hey, thanks for your reply.

I found 3 httpd.conf files but none of them contains "Listen 80"
We are using EasyPHP 3.0
 

Corali

Thread Starter
Joined
Jan 10, 2019
Messages
11
I assume you are using Apache web server. If so, then do this :


Open httpd.conf file in your text editor. Find this line:

Listen 80

and change it

Listen 5000

After change, save it and restart apache.
In the virtualSVN folder where I have the third httpd.conf file, there I have port 81 but no 80. Doesn't really know what It means :(

edit: I see this now:

It is stuck on "Servers are restarting" from 10.1.18
https://imgur.com/a/tb2j32r (PIC)

 
Last edited:
Joined
Sep 21, 2007
Messages
11,985
Hi,

In the http.conf, the 'Listen' line allows you to specify which port number you want the Apache server to respond to. The protocol 'http' uses ports 80 normally, Lets say your sever ip address is 8.8.8.8 . If you specified Listen 80, then you would be able to connect to your server using 8.8.8.8:80 or simply http://8.8.8.8 .

Since you want to use port 5000, you would make the line 'Listen 5000". Then Apache will respond to 8.8.8.8:5000

However, what concerns me is that you found 3 http.conf files. I wouldn't know which one is the correct one to modify.
 

Corali

Thread Starter
Joined
Jan 10, 2019
Messages
11
Hi,
Thanks for your explanation I appreciate that.
The 3 httpd.conf files are located at:
C:\Program Files\EasyPHP3.0\conf_files
C:\Program Files\EasyPHP3.0\apache\conf
C:\Program Files\VisualSVN Server\conf
but I only found "Listen 81" and not 80.
I changed it to 5000 everywhere I saw 81 but still doesn't work, don't know If I am doing it right...
 
Joined
Sep 21, 2007
Messages
11,985
Was it ever successfully connecting at port 5000 ?

Maybe there is a Apache service and it needs to be restarted. Look in services.msc

If there is no service, then find the folder holding 'apachectl ' and use this command 'apachectl -k graceful-stop'

What OS are you running on the server ? Linux ? Windows ?
 
Last edited:

Corali

Thread Starter
Joined
Jan 10, 2019
Messages
11
The machine is running on win XP.
All I know is that when I opened my browser and type "our_machine_name:5000" it would open our wiki page. Not it doesn't work for a week, after a power outage.
I will try what you told me to and update here. Thanks!


EDIT: I cant find the service, so I looked for the file you mentioned but it doesnt exist. I found a lot of folder with the name "apache" thou (if this is related somehow).
 
Last edited:
Joined
Sep 21, 2007
Messages
11,985
Do a Windows Explorer search for '5000' . Perhaps it will find your previous configuration

If there are no results. Then do a network scan for that XP's ip address and see what ports are open. If a port is still open.

Disable the XP firewall - the XP is an internal machine right ? IE. no port forwards from the outside to the inside ?
 
Last edited:

Corali

Thread Starter
Joined
Jan 10, 2019
Messages
11
Hi,
I am using " Everything". It could not find '5000'.
Windows firewall is disabled.

When you say network scan what do you mean?
I opened CMD and type netstat then I can see what ports its listening to...
our machine is an internal machine and I believe the wiki http page was from the outside
 
Joined
Sep 21, 2007
Messages
11,985
I thought you mean the wiki was on the XP 'server' itself. If this wiki page is meant for the public, why would they put it on port 5000?
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top