Toshiba laptop doesn't turn on, on the first try.

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Asphyxiant

Thread Starter
Joined
Feb 5, 2015
Messages
2
(NOTICE: I'm not very tech savvy, so if I'm missing any information please be nice). I've been getting a reoccurring black screen problem, where i'll push the power button, get the battery, power, and wifi lights to switch on, but a black screen. It'll take at most 4 tries to turn on the laptop, and for a while the problem gone, but recently I've had to deal with it again.

My laptop is attached to a cooling fan, which is then connected to peripherals like my mouse, a wacom tablet, and a kraken headset. When turning it on, my cooling fan starts whirring, however my peripheral's external lights do not turn on.


Specs:
Operating System: Windows 7 Home Premium 64-bit SP1
CPU: Intel Core i7 3610QM @ 2.30GHz Ivy Bridge 22nm Technology
RAM: 8.00 GB Dual-Channel DDR3 @ 798MHz
Motherboard: TOSHIBA Portable PC (U3E1)
Graphics: Generic PnP Monitor ([email protected]) Intel HD Graphics 4000 (Toshiba) 2047MB NVIDIA GeForce GT 630M (Toshiba)
Storage: 931GB TOSHIBA MQ01ABD100 (SATA)
 

managed

Allan
Moderator
Joined
May 24, 2003
Messages
14,943
Do you have the same start up problem if the laptop's battery is removed first ?

EDIT : perhaps you can't remove the battery easily, what model Toshiba laptop is it ?
 

Asphyxiant

Thread Starter
Joined
Feb 5, 2015
Messages
2
Its a Toshiba Satellite P870, a model apparently no longer supported by Toshiba. Bought it approximately a bit over 2 years ago, and had this problem on and off for about a year. I no longer have the manual, and therefore have absolutely no idea where any internal hardware is. I'm also quite new to the physical aspect of computers,

EDIT: So i removed all of the peripherals, and attempted to boot up my laptop, it booted up immediately and is actually running faster than before. I'm going to attach the peripherals one by one to find the cause behind the black screen start-up.
 

managed

Allan
Moderator
Joined
May 24, 2003
Messages
14,943
That's good news. Please let me know what you find.

If you still want a manual you can download the User guide by clicking on this link :- https://www.mytoshiba.com.au/file/download/resource/file/22328/satp870-userguide.pdf

Hopefully you won't need it but you can get a Service manual by clicking this :- http://tech.nexicore.com/downloads/P870-P875_X870-X875_T572-T772.PDF

If you need a PDF reader to view them this is the one I use, the 'Viewer' version, 2nd one down :- http://www.tracker-software.com/product/pdf-xchange-viewer/download
Unzip then run the EXE file. (If offered Don't start the free trial, just install the free version).

EDIT : I'm guessing you're in Australia, must be nice to have warm winters !
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top