1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Toshiba Satellite doesnt boot

Discussion in 'Hardware' started by metalsign, Feb 14, 2005.

Thread Status:
Not open for further replies.
  1. metalsign

    metalsign Thread Starter

    Joined:
    Nov 12, 2003
    Messages:
    64
    I've got a Toshiba Satellite 1800-S204 laptop that won't bootup. It gets power. It seems like the battery charges. When I turn it on the power light comes on and it takes a few minutes and I can hear the processor fan come on. If I hold the power button down, the power button goes off, so it does actually turn on /off. The HDD LED doesn't come on at all, and I hear no HDD activity. The DVD drive doesn't open and doesn't seem like it works. The laptop screen was dark a few months ago and after reseating the inverter board, worked fine. It no longer boots up. It doesn't display anything on an external monitor either (pressing Fn&F5 should toggle displays. No buttons seem to have an effect. The original HDD was having the same problem, so a new one was installed with the same problem. I'm pretty sure it's not a HDD or display problem, but I could be wrong. Can this be related to memory? Or a strange power supply (the original was broken, so i replaced it with a different model with same voltage output)?

    I don't know what proc is in it, but I know it had Win2000 Pro on it. One day during a presentation, I got BSOD. After this, it never booted correctly.

    Any ideas? I always appreciate the help I get from this board, you'se are always so helpful.

    Thanks!
     
  2. Triple6

    Triple6 Moderator

    Joined:
    Dec 26, 2002
    Messages:
    52,889
    First Name:
    Rob
    This new power pack, same current and polarity of the plug?

    Could be the RAM, or motherboard. Try reseating the RAM, its usually easy to get to on the bottom.
     
  3. metalsign

    metalsign Thread Starter

    Joined:
    Nov 12, 2003
    Messages:
    64
    OKay, I reseated the RAM. Same problem. I switched RAM slots. Same problem. I reseated the inverter board again, and it started to boot. I was able to elect the cd that was in it. It asked me whether to boot into
    Normal
    Safe mode
    etc.

    I chose normal and it started to boot, then shut down and again won't restart.

    I'll buy some new RAM if it'll fix the prob.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/330552

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice