1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

total war rome loading problem

Discussion in 'Games' started by ghillie1, Nov 27, 2011.

Thread Status:
Not open for further replies.
  1. ghillie1

    ghillie1 Thread Starter

    Joined:
    Nov 27, 2011
    Messages:
    1
    I'm trying to install Total War Rome on my pc. I've played it before on this pc years ago and now play Napoleon Total War.
    Having seen new extras that can be put on Rome, I re-installed it and all went well until I tried to start the game. A intro picture appears first, then a small box "Demo shield" etc and then the Activison page, the disc whirrs in the pc....then nothing....then the disc stops and I'm back looking at my desk top. I've tried opening it in various ways, downloaded all the patches, re-installed again ...updated all possible drivers and still same result....Can anybody help ...please!
    My graphics card is NVidia Geforce 8800 GTX
    running on windows xp
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - total rome loading
  1. Pollybella
    Replies:
    3
    Views:
    204
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1028627

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice