1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Touchpad multi-touch/driver/synaptics problem

Discussion in 'All Other Software' started by danysan2002, Sep 12, 2014.

Thread Status:
Not open for further replies.
  1. danysan2002

    danysan2002 Thread Starter

    Joined:
    Sep 12, 2014
    Messages:
    1
    Hi there! I have a very annoying problem with my touchpad, I cant figure out how to enable the multi-touch gestures and drivers don't seem to work at all. First of all, my laptop is an Acer Aspire E5-572G-75MW. The drivers on the cd are for windows 8, (there's a synaptics and a elantech driver, when i try installing both of them, they install and at the end i get and "not needed, no device for update present"). I tried installing an elantech for w7 driver and i got an "ready to use" status at the end but absolutely nothing changed, no item in install/uninstall options, no item in control panel or in the mouse category, nothing. I tried the same thing with a W7 synaptics driver and i get the same status at the end but here i get two options:

    [​IMG]

    Again nothing changed, even after restarting. I am unable to see any settings regarding my touchpad, this is all i get in the control panel mouse category:

    [​IMG]

    That's all i get no matter what i try to install, i can't get anything to stick around, i've tried similar laptop's drivers, again with no luck at att and sucks since my touchpad has the clicking buttons integrated into the touchpad, its really annoying trying to scroll something. I tried enabling two-finger scrolling through some registry tricks but i couldnt find the right items and it didnt work. I dont even know what my touchpad's manufacturer is, all i get is that HID compliant mouse. Thank you!

    Tech Support Guy System Info Utility version 1.0.0.2
    OS Version: Microsoft Windows 7 Ultimate, 64 bit
    Processor: Intel(R) Core(TM) i7-4712MQ CPU @ 2.30GHz, Intel64 Family 6 Model 60 Stepping 3
    Processor Count: 8
    RAM: 3991 Mb
    Graphics Card: Intel(R) HD Graphics 4600, 1803 Mb
    Hard Drives: C: Total - 249899 MB, Free - 216520 MB; D: Total- 299999 MB, Free - 231667 MB; E: Total - 403866 MB, Free - 386627 MB;
    Motherboard: Acer, EA50_HWS
    Antivirus: None
     
  2. plodr

    plodr

    Joined:
    Jun 27, 2014
    Messages:
    16,094
    First Name:
    Liz
    I downloaded the manual. The touchpad is explained on p17 of the manual. Since the notebook came with 8.1 and I can only find drivers for Windows 8, you may not get full usage out of the hardware because you are not running the correct version of Windows. The best drivers come from the hardware manufacturer and they are no providing any Win 7 drivers.
     
  3. flavallee

    flavallee Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    78,620
    First Name:
    Frank
    Do the following in that Acer Aspire E5-572G-75MW laptop.

    Download MGADiag and save it to your desktop.

    Double-click on MGADiag.exe to launch the program.

    Click "Continue".

    Ensure that the "Windows" tab is selected (it should be by default).

    Click the "Copy" button to copy the MGA Diagnostic Report to the Windows clipboard.

    Paste the MGA Diagnostic Report back here in your next reply.

    ---------------------------------------------------------
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1133513

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice