Touchpad Problems (Left/Primary Click)

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

touchtoplay

Thread Starter
Joined
Apr 2, 2009
Messages
29
Hello everyone,
so I own a dv6tqe-7000, and I've had a strange problem. Sporadically, the left/primary click function on my touchpad would disable. I can still use the touchpad itself and the right click function but left clicking or tapping to click will not work.

I switched the functions in Synaptics (Right click to primary click, and left click to secondary click), and the left click ended working but the primary function still did not respond (ie. Right click didn't work). So I don't think it's a hardware issue.

There are some 'fixes' to this as I've discovered:
- Restart the laptop
- Kill explorer.exe function and re-open it
- Hold both mouse buttons down and move the touchpad around for half a minute. I don't know how or why this works but I read it on a post. Only tested one time though so don't read too much into it.

I've tried removing the battery and replugging it in. I'm also on the latest driver on Synaptics (I updated to the new one after it first occured, still happens). I am also on the latest BIOS. What is the problem and what could I do? Could it be the drivers (Should I uninstall Synaptics/touchpad in Device manager and do a clean install)?

I've found a couple people with the same problem but have yet to find a solution. Again, it is a sporadic event and honestly doesn't occur too often. Any advice would be appreciated.


EDIT: After switching the functions to confirm it was a software problem and not the touchpad hardware, I think it affected the problem when it occurred again. Just now, the right click didn't work (As in press right click on the pad wouldn't do anything). Left clicking would work, but here's the thing, it acted as a secondary click rather than primary.

It gets even weirder; it only acted as a secondary click outside of Firefox. In Firefox, the left click acted as a primary click while right still didn't do anything. Outside of Firefox (Windows Explorer, the desktop, etc), the left click acted as a secondary click. Restarting explorer.exe didn't work. The solution was to go to Control Panel -> Mouse -> (Synaptics) Mouse Settings -> Reset Devices. This seemed to have fixed it immediately.

If I had a hunch about what it may be, I'd say it was when I got my external mouse. I had my laptop for about a week and a half before I noticed this, and the problem should've occurred once in that time but only seemed to be apparent after I got my mouse. The mouse I got was the Logitech M705, and it has a mini-USB receiver. That being said, I just leave the USB in at all times and when I installed it I just let Windows install generic drivers.

Mouse works fine, both buttons act normal even when the touchpad buttons don't. Could Synaptics be running into problems with the Logitech mouse drivers? If so, why does it only occur sporadically?
 

touchtoplay

Thread Starter
Joined
Apr 2, 2009
Messages
29
Thanks for the post. Do you mean remove it and wait to see if it happens again? I know if I remove while the problem is happening it doesn't fix it.

It seems though using the 'Reset Devices' option also fixes the left/primary click issue. So this has to be a driver/software related issue right? I really hope it's not hardware related.
 
Joined
Aug 8, 2008
Messages
2,820
When you remove the driver and restart Windows will automatically reinstall the driver. So if the driver is corrupted this should fix the problem.
 

touchtoplay

Thread Starter
Joined
Apr 2, 2009
Messages
29
So go into device manager and uninstall the driver? Which driver, the HID-compliant mouse (Which I believe is the USB mouse) or the Synaptics PS/2 port touchpad? If both, which do I do first?

From your expertise and the symptoms I described (Switching functions to other button still doesn't allow primary click, resetting laptop or explorer.exe makes it work again, clicking Reset Devices makes it work again), this isn't a hardware problem is it?
 

touchtoplay

Thread Starter
Joined
Apr 2, 2009
Messages
29
Thanks for responding. I'll do it later tonight because I have a project to work on right now.

Also, since the problem is sporadic, I'll give it about 3-4 days to see if anything happens before confirming it works. If I do it tonight, I'll probably report back Sunday. If something happens during then, I'll post back here ASAP.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top