trouble installing .NET Framerwork

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

jackdup

Thread Starter
Joined
Jun 25, 2009
Messages
78
I am not sure if this is the right forum for this and if not would ask one of the mods to move it to the correct forum.

I had to do a complete new install of Microsoft XP Media Center Edition, and after doing the install download and installed all 80 updates from Microsoft.

A program I use requireds .NET Framework 2.0 howver am having problems installling it so decided to try 3.5 and again installation does not finish.

With 2.0 I get the following error

Product: Microsoft .NET Framework 2.0 -- Error 25015.Failed to install assembly 'C:\WINNT\Microsoft.NET\Framework\v2.0.50727\Microsoft.VisualBasic.Vsa.dll' because of system error: 0x80131107

I found an article on resolving this error at Microsoft but don't understand what they are instructing. Below is their response. If anyone can help me install either of these versions or tell me what the message below means I would appreciate it.

Turns out the customer had their COMPLUS_VERSION envionrment variable set to 1.1.4322 (the 1.1 framework). This caused mscoree.dll to load the 1.1 version of framework and use that to GAC the 2.0 assemblies.
The workaround is to delete that environment variable and rerun the install.

Below is the error log when installing 3.5
[04/17/10,13:25:57] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603
[04/17/10,13:25:57] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603
[04/17/10,13:25:59] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a is not installed.
[04/17/10,13:34:31] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603



 

DoubleHelix

Banned
Joined
Dec 9, 2004
Messages
24,388
.NET Framework 2.0 requires SP2 for Windows XP Media Center. Did you install that?
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top