trying to roll back video drivers on Dell laptop

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Jambonay

Thread Starter
Joined
Nov 1, 2003
Messages
57
I'm trying to roll back video drivers in my dell inspiron Laptop to cure crashing problem already isolated thanks to help from this forum. I can't figure out how to stop windows 2000 sp4 from loading the most current driver for this card. I keep manually deleting the newest rivers and then go to install the video drivers with a previous version and then when I go to device manager there is the newer (possibly the problem causing driver) What should I do?
 
Joined
Jul 29, 2003
Messages
287
Usually dell ships all of their machines with a driver disk(or cd). I would delete it from Device Manager and reboot the machine. When Windows finds the device use the driver on the cd. If you don't have a cd that came with the machine I would go to their website make a login for yourself, you will then have access to a page that will ask you to enter your servcie tag # or dell system. Then select downloads in the drop down box. You should find all of the drivers for your system. Write back if you have any questions.
TK
 

Jambonay

Thread Starter
Joined
Nov 1, 2003
Messages
57
I have tried this and have been able to roll-back the driver (according to device manager) but system still crashes. I wonder if the files have to be manually removed from the registry?
 
Joined
Jul 29, 2003
Messages
287
what s your model # of your Inspiron? and Service Tag # Do you now what kind of video card you have in it? What does the Device Manager name it? 2000 might be loading a completely wrong driver for it.
 

Jambonay

Thread Starter
Joined
Nov 1, 2003
Messages
57
Ispiron 7500, service tag # y7pqu, mobility P 8 meg, device manager says the same. I have been trying every driver on Dell's download page and the computer still ALWAYS goes black when opening a 3-d file in autocad 2002 as well as when clicking various hotlinks in internet explorer. The 3-d drawing file opens fine on my workstation which also runs windows 2000
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top