Turtle Beach sound card problem with Windows XP Pro

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

camsta

Thread Starter
Joined
Apr 22, 2010
Messages
5
Hi,
My computer running XP Pro has had a problem for a while concerning the sound card (possibly the drivers?) After a reboot, the sound works fine for a while, then starts going fuzzy/cutting out, then cuts out completely. I then have to reboot again to be able to get the sound working again.
My sound card is a Turtle Beach 8830 - relatively old I know but I don't have the $$ for a new one :(
Thanks,
Camsta
 

camsta

Thread Starter
Joined
Apr 22, 2010
Messages
5
I also have problems with choppy video playback but i'll leave you to answer the other question first ;)
Thanks in advance,
Camsta
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top