Two OS's loaded, only one showing at start up

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

tcox

Thread Starter
Joined
Oct 5, 2003
Messages
24
I had two operating systems installed, 98 on the D drive & XP on the C drive. XP Failed and as a result i reloaded XP by booting from the CD. This all worked fine, system loaded to C drive fine. However, originally (prior to reloading XP) when the computer booted up it gave me a choice of operating systems, XP or 98. This option no longer appears at start up, just goes straight to XP (on C drive). I did go into the System folder to select which OS is the default, however this only showed one system. I have confirmed that 98 is still actually installed on the D drive. Can anyone tell me (in simply language) how i can get the computer to acknowledge both systems again at start up. All suggestion greatly received...........!

Many thanks.
 
Joined
Feb 23, 2003
Messages
16,274
If you can get your system to boot into the repair console with the xp cdrom enter the repair console by clicking R at the prompt. Then type in the following commands and reboot when complete.
type FIXBOOT and answer yes after

type in the following commands and after each click enter and be sure to leave all spaces exactly as they are..

CD \
ATTRIB -H NTLDR
ATTRIB -S NTLDR
ATTRIB -R NTLDR
ATTRIB -H NTDETECT.COM
ATTRIB -S NTDETECT.COM
ATTRIB -R NTDETECT.COM
COPY X:\I386\NTLDR C:\ (X IS THE LETTER OF YOUR CDROM)
COPY X:\I386\NTDETECT.COM C:\ (X IS THE LETTER OF YOUR CDROM)

Then reboot wthout the disk
 
Joined
Feb 13, 1999
Messages
8,974
You can manually add it to the boot menu.

Select Start, right click My Computer, select Properties, select the Advanaced tab, click Setting button for Startup and Recovery, click Edit button, and add the line:

d:\="Microsoft Windows 98SE"

To the [operating systems] section. Then reboot to give it a try.
 
Joined
Sep 16, 2003
Messages
594
I'm not sure that this helps much but I think you can simply edit/check the boot.ini file on your pc. It could be that the timeout is set to 0 or 1 second hence you not being able to choose the operating system. Make sure hidden folders are visible and search for the boot.ini file, it should be in the root of your c drive.
(Remember, its a hidden file!) Open it with notepad or something similiar and see if there are two operating systems mentioned there. It should look something like:

default=multi(0)disk(0)rdisk(0)partition(1)\WINNT

but you should see two lines, the other one for Windows 98.

Also note the timeout period: Is it set to 0? If so, change it to 10!

Hope this helps!

Pileyrei
 
Joined
Feb 23, 2003
Messages
16,274
Or go to start/ control panel/system/advanced/startup and recovery/edit and copy and aste this boot ini to replace your current one:

[boot loader]
timeout=30
default=C:\WINDOWS
[operating systems]
D:\ = "Microsoft Windows 98 Second Edition" /fastdetect
multi(0)disk(0)rdisk(0)partition(5)\WINDOWS="Microsoft Windows XP Professional"
 

tcox

Thread Starter
Joined
Oct 5, 2003
Messages
24
Thank you to all who have tried to help me here from my original message, unfortunately having now tried all the options offerred the problem does still exist, time for the repair shop maybe. I have been able to get the second system (98 SE) option visible at start up but when you click on that at the options menu the computer just restarts. Fortunately i can still access the C drive (XP), phew !!!!!! I have also checked the time out for system selection and this is set at 30sec's. Anyway, thanks again, anymore theories still appreciated but perhaps it is time for a very reluctant shop visit.

Thanks again.
 
Joined
May 15, 2003
Messages
419
Originally posted by mobo:
Or go to start/ control panel/system/advanced/startup and recovery/edit and copy and aste this boot ini to replace your current one:

[boot loader]
timeout=30
default=C:\WINDOWS
[operating systems]
D:\ = "Microsoft Windows 98 Second Edition" /fastdetect
multi(0)disk(0)rdisk(0)partition(5)\WINDOWS="Microsoft Windows XP Professional"
You may want to trying setting the partition to 1 instead of 5.
 
Joined
Feb 23, 2003
Messages
16,274
That shouldn't make a difference but back in the recovery console you can try a bootcfg command to configure a new boot loader.
 
Joined
Feb 23, 2003
Messages
16,274
No web, you could have your disk broken down into 32 partitions and two systeems included and you would still have similar circumstances except the 5 would be a 32. As long as the boot loader is on c drive you're ok
 

tcox

Thread Starter
Joined
Oct 5, 2003
Messages
24
Thanks again to all, have tried all the options but still no go. Can get it to list the two OS's at start up but choosing the 98 system only brings up an error message or restarts the computer. I ahve noticed that both partitions are "primary 1".

Again, the support has been fantastic, ta.
 
Joined
Feb 23, 2003
Messages
16,274
And in there lies the trouble...You can only have one primary partition set to active.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top