1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Uefi/Legacy mode Windows installation

Discussion in 'Windows 10' started by fahmi1, Feb 19, 2017.

Thread Status:
Not open for further replies.
  1. fahmi1

    fahmi1 Thread Starter

    Feb 19, 2017
    I recently bought a hp pavilion 15 au038ca model. It came with a lot of bloatware so I decided to clean install Windows10. I used Windows Key Finder software to find my key since it's embedded in the bios, wrote it down and went ahead to install the same version as my previous windows: Windows 10 home x64.
    Before I even started with the installation, I could not see my device in the boot options( I was using a bootable usb drive). So I went to the bios and enabled legacy support and when I switched my laptop back on into boot device options, there it was: a usb drive option. So i selected it and went on ahead to do a clean install of windows. Now the problem is, whenever I load up system defaults in bios and save it, my laptop does not boot into windows. It gives me this error:

    Boot device not found.

    Please install an operating system on your hard disk.

    Hard Disk - (3F0)

    ...But as soon as I enable Legacy mode, it boots up into windows. My question is, how do I install windows into uefi mode and not legacy mode? Because I read many articles saying that uefi equals faster boot times and has more advantages than the older legacy mode. And whenever i try making a bootable uefi disk, there is still no device options when only the uefi mode is on. But when the legacy mode is on, then I can see my disk under the boot device options.
    Second question, how do I change my hard disk partition to gpt from mbr?
    Thank you
  2. bassfisher6522


    Aug 8, 2008
  3. crjdriver

    crjdriver Moderator

    Jan 2, 2001
    You do not need to turn off secure boot and you probably should not turn off secure boot. Here is what happens. When the system is in legacy mode [how you installed windows] It boots from whatever drive you installed windows. In eufi mode, it boots from the windows boot loader which is installed on a FAT32, hidden partition of the drive.
    The only reason I can see to turn OFF uefi is to dual boot with win and linux OR to install a 32bit version of linux. Most [if not all] 64bit distros work fine with uefi.

    Here is what I would do;
    1 Start over. Set your bios the way it is supposed to be set ie secure boot ON.
    2 Check your manual for any quick boot or fast boot option. If you have this, turn it off for now. Save settings and restart with your win10 install usb inserted.
    3 During POST or when you see a splashscreen, hit the F9 key. This should bring up a boot menu; select to boot from the usb. Be sure to delete all partitions on the disk so you get rid of the previous install. The disk should be blank; let win setup create partitions however it wants.
    4 Install windows, updates, drivers, etc, etc, etc. Once you are all finished, you can again enter the bios and enable fast boot [If you want] FWIW, I leave it disabled on my asus laptop.
    Last edited: Feb 20, 2017
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1185614

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice