Unable to access BIOS/UEFI - Empty UEFI Screen

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

manuleka

Thread Starter
Joined
Jan 20, 2011
Messages
50
Platform:
Windows 10 Pro
GA-X79-UD5 rev 1.0
E5-2670
40GB DDR3 Quad
512 SSD
GTX 1060

Scenario:
Upgraded Video Card from GTX 560 Ti to GTX 1060 Strix, machine boots but no video output or just black/blank screen.

Did a bit of online research and realize that two ways of fixing this
1. Change PCI setting to Legacy in BIOS/UEFI
2. Update to latest BIOS.

I decided to try and update BIOS to latest BETA (13w) using @bios from Windows. Everything went ok, reboots fine and still does now with Windows loading no problem, BUT i can't get to BIOS/UEFI???

All i get is the UEFI empty blue screen, no menus/options, just blank screen...

So i thought maybe i can reverse back to previous BIOS from windows but program wouldn't allow this. I tried sticking BIOS file in USB but the problem is i can't get to BIOS.

I Have tried running backup BIOS as board has two, but still same problem.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top