1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Unable to access BIOS/UEFI - Empty UEFI Screen

Discussion in 'Hardware' started by manuleka, Feb 2, 2017.

Thread Status:
Not open for further replies.
  1. manuleka

    manuleka Thread Starter

    Joined:
    Jan 20, 2011
    Messages:
    50
    Platform:
    Windows 10 Pro
    GA-X79-UD5 rev 1.0
    E5-2670
    40GB DDR3 Quad
    512 SSD
    GTX 1060

    Scenario:
    Upgraded Video Card from GTX 560 Ti to GTX 1060 Strix, machine boots but no video output or just black/blank screen.

    Did a bit of online research and realize that two ways of fixing this
    1. Change PCI setting to Legacy in BIOS/UEFI
    2. Update to latest BIOS.

    I decided to try and update BIOS to latest BETA (13w) using @bios from Windows. Everything went ok, reboots fine and still does now with Windows loading no problem, BUT i can't get to BIOS/UEFI???

    All i get is the UEFI empty blue screen, no menus/options, just blank screen...

    So i thought maybe i can reverse back to previous BIOS from windows but program wouldn't allow this. I tried sticking BIOS file in USB but the problem is i can't get to BIOS.

    I Have tried running backup BIOS as board has two, but still same problem.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1184770

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice