Unable to install driver for my CHIC USB Optical Mouse

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

sweetnessuk

Thread Starter
Joined
Nov 6, 2011
Messages
3
I have tried to install my USB CHIC Optical Mouse M4, S/N 1108003565 800/1000 dpi.
An error pops up when it tries to install the mouse when it should just be plug and play. I did have a look in Device Manager and did see 1 Unknown Device. I tried to update it from there but still could not find the software online.

I have read information from another user regarding the inf file via windows, but it wasn't specific enough and I did not understand.

Please can you advise further.
 
Joined
Aug 1, 2003
Messages
51,988
Do other USB devices work?

What are you installing it on (make/model)?

Is there any other mouse device on the machine?
 

sweetnessuk

Thread Starter
Joined
Nov 6, 2011
Messages
3
Do other USB devices work?

What are you installing it on (make/model)?

Is there any other mouse device on the machine?

Reply:

I am installing it onmy laptop, Manufacturer is Novatech.
All I can see in Device Manager under the mouse drop down is what I believe to be the laptop mouse pad driver (PS/2 Mouse). I pulled out the old mouse and tried to uninstall that driver, and when it reinstalled when the laptop was turned on without the old mouse plugged in.
 
Joined
Aug 1, 2003
Messages
51,988
If you have a mouse pad, how did you "pull out" the old mouse?

Be aware that PS/2 devices are not hot-pluggable and you can damage the mainboard by connecting or disconnecting those devices with the power on.
 

sweetnessuk

Thread Starter
Joined
Nov 6, 2011
Messages
3
When I say I have a mouse pad, it's just the touch tuch pad ont he laptop, but my old usb mouse still works and when I pull that one out, the USB Device in Device Manager disappears which it should do. I am trying to get my new mouse to new, but it's won't install the driver via internet.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top