Unable to log into Windows 2000 machine

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Milissa

Thread Starter
Joined
Sep 22, 2003
Messages
4
Hello,

I have a Dell GX1 with Windows 2000 Professional.

When after I type my user name and password in the proper fields and click on "OK" it take me right back to the log on screen where I enter my user name and password.
I never get to my desktop and I don't see any of the information boxes that come up like "loading your personal settings".
I have even tried booting into Safe Mode but I have the same problem.

Any ideas?

Thanks in Advance
 

Rache

Banned
Joined
Sep 30, 2002
Messages
1,398
Hi and welcome.

Try the repair option:

Boot from w2k cd, and you'll be prompted to enter repair console in next screen. Don't enter repair console here but select install. Then you'll be shown the listed os's on pc. Choose repair option. But be careful 'cos at this stage when I did it it installed another w2k os and it didn't repair existing os (could have been my mistake).
 
Joined
Feb 23, 2003
Messages
16,274
You will lose all windows updates that way as well but you should be free from the problem..
 
Joined
Jul 29, 2003
Messages
287
You see, Windows 2000 expects this file to reside in a certain location. If
you play around with your hard disk then your drive letters may change and
userinit.exe may no longer be where Windows 2000 is looking for it. You
can no longer log on.

Here is the quick fix:
- Place a copy of userinit.exe on every drive you have, always into
\nt4\system32.
If your disk uses NTFS partitions then you probably have to install it
temporarily
in some other NT or W2000 machine to create these files.

And here is the permanent fix: Once you log on, run regedit and do this:
- Find HKLM\System\MountedDevices
- Find \DosDevices\C:, and rename it to \DosDevices\Z:
- Find the new drive letter and rename it to \DosDevices\C:
- Rename \DosDevices\Z: to the freed up drive letter

You may need to use RegEdt32.exe to give yourself appropriate permission
to perform these changes.

UserInit.exe must reside where the registry expects it to be:
HKLM\Software\Microsoft\Windows NT\Current Version\Winlogon\Userinit:
Reg_SZ:C:\WinNT\System32\userinit.exe

You should also run fdisk /mbr to erase the disk signature associated
with the volume GUID

The following Microsoft Knowledge Base articles apply: Q69013, Q249321,
Q234048, Q221799, Q227364, Q227605, Q225025, Q51978

Good luck!
TK
 
Joined
Jul 29, 2003
Messages
287
I would try this anyways because if you just go and copy a new userinit.dll to winnt/system32 directory and the login will work fine. However, the desktop is messed up, and control panel doesn't work very well at all. Any you might as well just reinstall Windows. But if anyone else comes up with anything else that I am not aware of I would try that before this.

TK
 

Milissa

Thread Starter
Joined
Sep 22, 2003
Messages
4
Thanks for the advise.

Everything is working now after I restored the permissions to the file.
My profile is loading properly and I am not seeing any errors in the event log.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top