1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

unable to obtain ip address

Discussion in 'Networking' started by magnolia, Mar 10, 2002.

Thread Status:
Not open for further replies.
Advertisement
  1. magnolia

    magnolia Thread Starter

    Joined:
    Dec 9, 2001
    Messages:
    7
    My daughter has cable modem connection (Chambers) and one more computer networked to hers on the telephone line home network (I can't remember what it is called).
    She recently installed xp home and is having trouble with her computer obtaining an ip address after the lease expires (for some reason she gets a 2 hour lease from the cable company) Windows was assigning the 169.x.x.x address but she disabled APIPA in the registry now she gets a 0.0.0.0 address. She tried ipconfig/ renew but she gets the message that she is trying an action on ..... that is not a socket (?)
    She disabled her home network..
    She can get a new ip address if she reboots, but she is getting tired of rebooting every two hours.
    We are all stumped, (including the Cable Co. Tech support, which is no big surprise)
    Any hints would be much appreciated
     
  2. brianF

    brianF

    Joined:
    Dec 2, 1999
    Messages:
    12,041
    Does it do the same thing if the home network is disabled???

    I am sure the cable company checked and made sure the computer was set to use dhcp.

    The 169.xxx.xxx.xxx address is a windows internal default address meaning that the modem couldn't find or get an ip from the dhcp server.

    Has she tried going into command prompt and releasing the ip first, then renewing

    should be

    ipconfig /release
    ipconfig /renew

    The modem will contact the dhcp server and remove the current ip, if it can't contact the server it will give an error message saying as much.

    After release, then try the ipconfig /renew.

    If for some reason it's not contacting the dhcp server it's the cable companies problem, something is not setup correctly on their end of the connection.
     
  3. magnolia

    magnolia Thread Starter

    Joined:
    Dec 9, 2001
    Messages:
    7
    she tried the ipconfig/release and ipconfig/renew. It won't renew. She got an error message saying she was a attmepting an action on something that wasn't a socket.(?)
    The cable company says its not their fault of course.
    She has disabled the other home network... still nogo.
     
  4. brianF

    brianF

    Joined:
    Dec 2, 1999
    Messages:
    12,041
    whole bunch of techie stuff here on checking the registry settings for the tcp/ip network. Make sure to backup the registry first if you attempt this. Should be able to run regedit, then go to file, export, select all, and save a copy on your desktop or where ever, in case it's needed the file will be a .reg file and you can reimport it if problems arise.
    TCP/IP and NBT Configuration Parameters for Windows XP

    Another though would be to go to www.dslreports.com, click on the tools option, tweak test, run the test, see what it suggests for changes to improve the settings.

    I would for sure check this setting

    Lease
    Key: Tcpip\Parameters\Interfaces\ ID for Adapter
    Value Type: REG_DWORD - Time in seconds
    Valid Range: 1 - 0xFFFFFFFF
    Default: None
    Description: This parameter is used by the DHCP client service to store the time (in seconds) that the lease on the IP address for this adapter is valid for.
     
  5. angelina

    angelina

    Joined:
    Mar 11, 2002
    Messages:
    1
    also. if i have a 169.x. IP when I run ipconfig/release it will not release the ip. it will only release the ip if it is a dhcp assigned one. and i have disabled apipa in the registry by following the directions from a microsoft bullitin but it has not worked. i also tried to disable it on the adapter connected to the cable modem, but that did not work either. i get a ms assigned ip. it did work for a short period, but has gone back to assigning a ms ip address. the error log
    Cable modem log:
    020310093103 5-Warning D521.0 DHCP Lease Renewal Failure.
    020310093057 5-Warning D521.0 DHCP Lease Renewal Failure.
    020310093052 5-Warning D521.0 DHCP Lease Renewal Failure.
    ************ 8-Debug T509.0 Acquired DS with status NO SYNC, DS Freq 567000000, US Id 0
    Surfbord Configuration
    Frequency Plan: North American Standard/HRC/IRC
    CM Ethernet IP Address: 192.168.100.1 <--- i dont think this should be)
    Upstream Channel ID: 5
    Frequency (Hz): 573000000

    my windows xp system event view gives the following errors all related to dhcp (these are abreviated because I can not copy and paste).

    warning: computer unable to renew ip address: semaphor timeout has expired.
    Error: compute has lost its lease
    warning: unable to automatically configure ip parameters: a socke operation encountered a dead network.
    Warning: unable to optain an address from the dhcp server: an operation was attempted on something that is not a socket.


    I wondering if windows is assigning an ip address and it wont release it then the pc would be unable to talk to the dhcp server? again the dhcp will assign and address on reboot.
     
  6. sshaver

    sshaver

    Joined:
    Oct 25, 2001
    Messages:
    8
    Try uninstalling and reinstalling TCP/IP. If that does not work then try the same thing with the network card and TCP/IP.
     
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/72022

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice