1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Undeletable trash on external hard-drive (MAC)

Discussion in 'Apple Mac' started by Sinovera, May 16, 2012.

Thread Status:
Not open for further replies.
Advertisement
  1. Sinovera

    Sinovera Thread Starter

    Joined:
    May 16, 2012
    Messages:
    1
    Hi there,
    I'm experiencing a strange problem on my external HD. I'm a MacBook Pro user but I also have Windows Vista on BootCamp. The external is WD Elements.

    When I plug in my external while on my Mac partition, the trash can automatically fills up with old video files that I put in there a long time ago. When I press "Empty" it makes the usual trash crumpling sound then closes the Trash window as normal but the same files are still in there. If I attempt to take the file out of Trash (normally you do this by right clicking and pressing "Put Back" but that option is NOT there) it begins to *copy* the file to the destination (so the file is still in the Trash even if I "move" it out). The copied file is fine, I can open it, watch it, and delete it. Once I eject the HD, the files disappear from the Trash. When I plug it in while on my Windows Vista partition, there is nothing in the trash.

    I've tried using Terminal commands to force it to delete the files in the Trash but the files persist. Any suggestions?

    Thank you.

    Extra info:
    -If I put a new file from my external to the Trash can and press empty, it deletes only the new files.
    -My Mac partition is able to read and write to the external just fine, as is my windows partition.
    -The files that are now stuck in Trash were originally put there from my Mac partition.
    -The files are not locked, and I have permission to read and write (it says so in the "Get info" panel).
     
  2. mister2

    mister2

    Joined:
    Apr 28, 2012
    Messages:
    35
    I have had the same problem.

    I don't remember how I eventually fixed it. I think I copied all of my files off and formatted the drive.





    I will try to think a little more about what I did and see if I can recreate a solution. I know I spent about 3 evening on search engines and downing large cups of joe in utter frustration though.
     
  3. Headrush

    Headrush

    Joined:
    Feb 9, 2005
    Messages:
    2,488
    What format is the external HD?

    Have you tried repair disk and/or repair permissions on the external partition using /Applications/Utilities/Disk Utility?
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1053517