Unidentified Operating System on Drive C?

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Tombstone

Thread Starter
Joined
May 8, 2003
Messages
33
Please help me. I am setting up XP for a friend of mine, and I have a most peculiar situation.

Every time the PC boots, I get the following message:

~~~~~~~~~~~

Please select the operating system to start:

Microsoft Windows XP Professional
Unidentified operating system on drive C

Use the up and down arrow keys to move the highlight to your choice.
Press ENTER to choose.

For troubleshooting and advanced startup options for Windows, press F8.

~~~~~~~~~~~

The thing is, the drive was empty before I started XP setup. I deleted the old FAT32 partition and created a new FAT32 partition. I used Partition Commander v8.0 for this. It's a 160GB Western Digital. (No, I don't want to use NTFS. I have my reasons.)

Something odd though, when I created the new partition, it came up with 74MB used. Now that seems a mite excessive for filesystem overhead, even for FAT32. Yet when I delete the partition, the drive capacity and drive free space match exactly with no partitions defined. I don't know if this is related to the reoccurring XP multi-boot prompt or not.

I've deleted and re-created the partition several times, with Partition Commander and Win98 FDISK (from a boot diskette) both (I've installed WinXP on this machine four times now), and nothing changes. I even tried "FDISK /MBR" from a Win98 boot diskette DOS prompt. Still nothing. I still get the XP multi-boot prompt (and the mysterious 74MB used on a supposedly empty FAT32 partition).

This 160GB disk wasn't even the original OS disk. My friend bought it and installed it as a secondary. I swapped the two drives out because the previous OS disk was only 20GB (an IBM Deskstar).

I've installed XP (Home and Pro) on several different machines, and I've never had this happen. WTF is going on, and how do I fix it?

Please help me. This is frustrating.
 

Tombstone

Thread Starter
Joined
May 8, 2003
Messages
33
I figured it out, thanks.

This is the fix:

Boot to Windows XP
Right click on My Computer, select Properties.
Click Advanced tab.
In Startup & Recovery section, click Settings button.
Deselect "Time to display list of operating systems:"

That's it. Thanks to the guys over at Annoyances.org for the solution.

This one's ready for the archives.
 
Joined
Jan 27, 2001
Messages
741
Well it looks like you still have part of your hd that is unusable. You can use xp disk to format to the fat32 partition. You dont need third party software.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top