1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Unidentified Operating System on Drive C?

Discussion in 'Windows XP' started by Tombstone, Feb 4, 2005.

Thread Status:
Not open for further replies.
  1. Tombstone

    Tombstone Thread Starter

    Joined:
    May 8, 2003
    Messages:
    33
    Please help me. I am setting up XP for a friend of mine, and I have a most peculiar situation.

    Every time the PC boots, I get the following message:

    ~~~~~~~~~~~

    Please select the operating system to start:

    Microsoft Windows XP Professional
    Unidentified operating system on drive C

    Use the up and down arrow keys to move the highlight to your choice.
    Press ENTER to choose.

    For troubleshooting and advanced startup options for Windows, press F8.

    ~~~~~~~~~~~

    The thing is, the drive was empty before I started XP setup. I deleted the old FAT32 partition and created a new FAT32 partition. I used Partition Commander v8.0 for this. It's a 160GB Western Digital. (No, I don't want to use NTFS. I have my reasons.)

    Something odd though, when I created the new partition, it came up with 74MB used. Now that seems a mite excessive for filesystem overhead, even for FAT32. Yet when I delete the partition, the drive capacity and drive free space match exactly with no partitions defined. I don't know if this is related to the reoccurring XP multi-boot prompt or not.

    I've deleted and re-created the partition several times, with Partition Commander and Win98 FDISK (from a boot diskette) both (I've installed WinXP on this machine four times now), and nothing changes. I even tried "FDISK /MBR" from a Win98 boot diskette DOS prompt. Still nothing. I still get the XP multi-boot prompt (and the mysterious 74MB used on a supposedly empty FAT32 partition).

    This 160GB disk wasn't even the original OS disk. My friend bought it and installed it as a secondary. I swapped the two drives out because the previous OS disk was only 20GB (an IBM Deskstar).

    I've installed XP (Home and Pro) on several different machines, and I've never had this happen. WTF is going on, and how do I fix it?

    Please help me. This is frustrating.
     
  2. Tombstone

    Tombstone Thread Starter

    Joined:
    May 8, 2003
    Messages:
    33
    I figured it out, thanks.

    This is the fix:

    Boot to Windows XP
    Right click on My Computer, select Properties.
    Click Advanced tab.
    In Startup & Recovery section, click Settings button.
    Deselect "Time to display list of operating systems:"

    That's it. Thanks to the guys over at Annoyances.org for the solution.

    This one's ready for the archives.
     
  3. ezymony

    ezymony

    Joined:
    Jan 27, 2001
    Messages:
    741
    Well it looks like you still have part of your hd that is unusable. You can use xp disk to format to the fat32 partition. You dont need third party software.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/326846

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice