1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

URL object missing from File Types

Discussion in 'Windows XP' started by Anodhask, Jul 9, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. Anodhask

    Anodhask Thread Starter

    Joined:
    Jul 9, 2007
    Messages:
    3
    When tried to associate file extensions with programs that will open them in Windows Explorer/Tools/Folder Options/File Types, I accidentally wrongfully edited the following URL object, and had it disappeared:

    (NONE) URL:File Transfer Protocol

    As it has no actual extension, my tries to retrieve it were futile. I tried inputing the following values:

    1. Under the File Types tab, I went "New"
    2. For "File Extension" I typed "(NONE)" (without quotes)
    3. I extended the "Advanced" button and selected "URL:File Transfer Protocol"
    4. Clicked "OK"

    I got the following:

    [​IMG]

    As you can see, it was related to only as a "NONE" without the "URL:File Transfer Protocol" suffix I selected in step 3.
    This was not the case when it had stood there by default, before its deletion.
    Afterwards, I tried to furthermore edit this just created object, by adding values that were common to "URL:Gopher Protocol", "URL:HyperText Transfer Protocol" and "URL:HyperText Transfer Protocol with Privacy", and it looked like this:

    [​IMG]

    I clicked "OK", just to find that there were no changes; it remained the same. It was still related to as a "(NONE)", without "URL:File Transfer Protocol" suffix, as seen on the picture:

    [​IMG]

    Instead, it should' ve looked like the following three URL objects:

    1. [​IMG]

    2. [​IMG]

    3. [​IMG]

    I' ve tried reinstalling Firefox, thinking it would re-register the missing URL entry, it didn' t. I tried to copy my friend' s (who runs the same OS - XP Professional) entries for this URL object and it also didn' t work. Also tried associating it with Internet Explorer but it didn' t work. I' ve tried everything I know of, and had posted this issue on 3 forums, but had no luck.
    Could you please tell me of something that I may not have yet tried? How can I re-register this URL object so it appears just as it did by default? Could perhaps a registry fix or a DLL injection do the trick?
    Any kind of help would be so greatly appreciated. Thanks in advance.
     
  2. ozrom1e

    ozrom1e

    Joined:
    May 15, 2006
    Messages:
    11,849
    Welcome to TSG....

    Try using system restore and go back before this happened.
     
  3. Anodhask

    Anodhask Thread Starter

    Joined:
    Jul 9, 2007
    Messages:
    3
    Thanks!
    OK, I' ve tried System Restore to a day before it happened, but it didn' t work.
    I' ll have to wait a bit more, someone will maybe have an answer, but thanks anyways!
     
  4. Frank4d

    Frank4d Retired Trusted Advisor

    Joined:
    Sep 10, 2006
    Messages:
    9,126
    All of those "[None] URL" types are shown as open with blank (nothing) on my PCs.
     
  5. Anodhask

    Anodhask Thread Starter

    Joined:
    Jul 9, 2007
    Messages:
    3
    It' s okay if it displays them so, you can always associate them with whatever browser.
    But my problem is that it won' t recognize it as an URL object even after I edit it just the way it should be. I circled the error on the screenshots orange -

    Details for '(NONE)' extension
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - object missing File
  1. iono
    Replies:
    0
    Views:
    150
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/593550

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice