1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

USB and Video not Working

Discussion in 'Hardware' started by Christian15, Aug 13, 2019.

  1. Christian15

    Christian15 Thread Starter

    Joined:
    Aug 13, 2019
    Messages:
    1
    hello!
    I recently ordered a Gigabyte GA-H110M - S2H and replaces it with my old motherboard. I linked up all the parts including a new 600 watt power supply and a cpu water cooling unit. I am currently stuck on figuring out on how to get my video and USB ports to start working. I have removed my ram sticks, restarted the system plenty of times and am no closer to finding out what’s wrong. My Cpu fan is currently working and so is the graphics card that I put in. If anyone knows how to fix this, it would be greatly appreciated.
     
  2. lunarlander

    lunarlander

    Joined:
    Sep 21, 2007
    Messages:
    11,411
    You said your graphics card is working. But you asked about getting video working. What is this video that you are referring to if it is not your graphics card?

    Did you install all drivers on the motherboard CD ?
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...

Short URL to this thread: https://techguy.org/1231408

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice