1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

USB card device doesn't work

Discussion in 'Windows XP' started by tauro_kpo, Feb 17, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. tauro_kpo

    tauro_kpo Thread Starter

    Joined:
    Feb 17, 2007
    Messages:
    7
    Good-day to you all, I'm here with a necessity.
    The necessity to find out the solution to a problem that let me dismayed.

    I'm using Win XP SP 2, and short time ago, I've bought a memory card reader, those little usb.

    The problem it is that, when I use it on my computer I can't copy any files, nor from the card to any folder of my hard disk, nor from any file from the hard disk to the card.
    Seldom it works, and I can pass one file, but very seldom. If I want to transfer all the content of the card for example (1 gb) I can't. And when I want to see files that are in the card, it takes a long of time, just to visualize a single file, and when I want to copy it, I just can't or it takes a huge time.

    I tried this device in other computers running WIN XP SP 2, and it worked out.
    I have no doubts at all the that the problem is in my pc, and for sure in Win XP.
    It is not unrelated to say that other USB devices, such as Mp4, or Mp3 players, etc. etc. etc. (of high speed file transferring USb 2) work well.

    Not long time ago I tried installing my WIN XP SP 2, in another partition, just for trying if my WIN installation was bad or somethjng, but it doesn't work in the other WIN installation either.

    I checked out the CMOS and it is all as it should be. (I mean the USB configuration) it is marked "Enabled" in all the options.

    I tried connecting it in all other ports (from the front and back) but it didn't work either.

    The exact error is this

    "The request could not be performed because of an I/O device error."

    I just know that I don't know anything.

    What should I do to fix things out?

    I thank you very much for your suggestions and answers.
     
  2. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
    Does the problem just occur on very large files?

    If you open the Device Manager (run devmgmt.msc) and look under the USB tree -- is there an entry there for an "Enhanced" USB controller? If so, is it "working properly"?

    You might try doing what is known as a USB "cleanup":

    USB CLEANUP

    First set a System Restore point and test it: start > run: msconfig > Launch System Restore.

    The standard approach to these problems is to remove all the USB devices in the Device Manager and let Windows reinstall them. But there is a special technique to it.

    I am uploading a registry patch you will need to download, unzip and run. Confirm the merge to the registry.

    It is the patch described in JohnWill's note here:

    http://forums.techguy.org/hardware/449735-usb-problem.html#post3435808

    Once you have installed the patch, follow the rest of his instructions.

    Note: in some cases Windows does not have the proper install path for the information files required. If the New Hardware Wizard prompts you for an install location, point it to:

    c:\windows\INF

    This is a hidden directory, so you will need to have "show Hidden Files" enabled in Folder Options > View to see it.
     

    Attached Files:

  3. tauro_kpo

    tauro_kpo Thread Starter

    Joined:
    Feb 17, 2007
    Messages:
    7
    Thank you very much for your help.
    The problem ocurrs with both, large and small files, even sometimes creating folders.
    But I found that, the first times it doesn't work properly, but if you keep trying, some times it works, that's the weird.
    I checked if there was an enhanced usb controller, and there is, and it is working properly.
    The idea is to make it work correctly always, not just some times with goodluck.
    I tried the process you told me, as you described it. But I'm so sad, it just didn't work.
    It was like always, the only thing was that I had to load the drivers (they auto-loaded) for using the card reader, but it stills working bad.
    Thank you for helping, I hope you know what's the solution to this.(y)
     
  4. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
    >> Hmm, what is brand/model name of the card reader?

    I only have one so-called 9 in 1reader and it does not require any driver installed.

    >> when you plug it in, do you get a "detection" sound, and does the "safely remove hardware" icon appear in the System Tray?

    If you open the Device Manager and look under "Disk Drives" (check show hidden devices first), do you see something like what I have here in the attachment?

    Try removing all the "CARD" devices you see there and any "faded" or "ghost" entries and reboot.

    You may need to experiment with the "optimize" choice in policies, but if you do you should always use the "safely remove hardware" wizard before unplugging the device. If you haven't been doing this it may be damaged.
     

    Attached Files:

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - card device doesn't
  1. ImWolf
    Replies:
    1
    Views:
    533
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/544781

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice