1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

USB device not recognised (USB-IDE Bridge)

Discussion in 'Hardware' started by rincewindwiz, Sep 24, 2008.

Thread Status:
Not open for further replies.
  1. rincewindwiz

    rincewindwiz Thread Starter

    Joined:
    Sep 24, 2008
    Messages:
    44
    HI,
    I have (several) USB disc drives.
    In this case, one is an old 2.5" drive in an enclosure the other a Freecom500Gb drive

    On one machine (Tecra M5 XP Pro SP3) both are recognised and work fine.

    On the other machine (T9000 XP Pro SP3) with a Belkin USB2.0 PCMCIA card
    (with the power also plugged in) the Freecom is recognised and works fine; the other
    USB drive is flagged as 'unknown device'

    I am pretty sure the Tecra identifies it as USB-IDE Bridge and automatically loads the driver

    I have also tried plugging in the enclosure to the native (USB1.0) port but XP still will not recognise the drive.

    Where can I find an XP USB to IDE bridge driver and most importantly
    How can I get XP to install the right drivers for this device?
    (and of course, will it help!!)
    TFIA
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/752846

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice