1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

USB Devices Not Recognized in XP

Discussion in 'Multimedia' started by NumTarn, Jan 13, 2013.

Thread Status:
Not open for further replies.
Advertisement
  1. NumTarn

    NumTarn Thread Starter

    Joined:
    Jan 13, 2013
    Messages:
    3
    My computer Dell GX280 Win XP SP3, suddenly will not recognize my Verbatim ext HD, my USB2 hub or my Tascam recorder. Computer has 6 USB ports. 2 on front, 3 on the back use USB mouse, kybd & Huawei internet modem.All work normal. The Verbatim, USB2 hub and Tascam recorder devices will not work with ANY port. "Device Not Recognized" - All USED to work normal. Devices says I have an "enhanced" port, which the Huawei is plugged into, but will not recognize any of these devices. I have an older USB1 hub which works but keeps telling me I need USB2 port (for the Skype camera)..Although "properties" says everything is working normal. It is not.
    Computer cannot find any USB 2 ports, and wont recognize certain devices ..These devices all work on another computer...???:confused: I m outta my depth ...HELP - DOES ANYBODY HAVE ANY SUGGESTIONS ?
    Thanks

    NumTarn
     
  2. t bone

    t bone

    Joined:
    Jul 1, 2004
    Messages:
    1,203
    have you tried unplugging the usb devices and restarting your computer.
    then plug them in one at a time and see if the your system recognizes them
     
  3. NumTarn

    NumTarn Thread Starter

    Joined:
    Jan 13, 2013
    Messages:
    3
    Hi T-Bone, thanks for the suggestion. I have tried that. I have uplugged everything including power supply and started again ..
    power,usb kyb,usb mouse,etc. It ends up the same. The usb2 hub will not be recognized..(it works on other computers).. Apart from my kyb + mouse only my internet connection + older usb1 hub will work.
    I have tried different connections same story. Sometimes, I have noticed a usb device that will not work in any port, WILL work if I plug into the USB1 hub??
    i will keep wrestling with it (after work , what fun!!)
    Cheers,

    NumTarn (means sugar in Thai)
     
  4. t bone

    t bone

    Joined:
    Jul 1, 2004
    Messages:
    1,203
    have you tried downloading the latest driver for that part of your system
    dell drivers here
     
  5. dai

    dai

    Joined:
    Mar 6, 2003
    Messages:
    11,198
    check usb enabled in the bios

    try a usb reset

    in the device manager click on view at the top and in the dropdown
    show hidden devices
    then uninstall all listed usb items
    turn the computer off
    unplug usb plugs
    reboot twice
    replug in the usb plugs
     
  6. NumTarn

    NumTarn Thread Starter

    Joined:
    Jan 13, 2013
    Messages:
    3
    Thanks, I will give that a try and post a result
     
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - Devices Recognized
  1. accordman1
    Replies:
    7
    Views:
    281
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1085093

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice