USB External Device Nightmare

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

macdickerson

Thread Starter
Joined
Mar 6, 2020
Messages
1
Hello,
I am a college student and I record all of my lectures (which are very necessary to me passing) on a Sony IC Recorder ICD-UX560. I have a 2017 MacBook Air (OS Sierra: 10.12.6) and one of my USB ports doesn't work. Well, I decided that this evening of all times (right before midterms) to try and insert my recorder into that plug. It connected and disconnected continuously for about 5 seconds, the "do not remove until device is ejected properly" message was shown and hidden an equal number of times. The brilliant individual that I am, decided to "fix" the issue by trying to straighten out the seemingly bent connectors inside the physical port with my pocket knife. As anyone who thinks would guess (cause ya know, electrons and their love of conductivity), I got sparks and a USB devices disabled message on my screen. I continued to try and plug my device in; over... and over... but to know avail (because of this I am insane by Einstein's standards). After this I gave up on the failed port, enabled USB devices, and returned to the perfectly fine USB port that I should have used all along. Alarmingly, my device didn't show up on my desktop(a major problem as I have the last 4.5 weeks of lectures stored on its internal hard drive). So, I scoured the internet to try and find a solution, tried a few and heres the situation I have at hand:

USB device is nowhere to be found except in system information. Disk utility won't show it, just my hard drive. Downloaded a program titled "Disk Drill" which is supposed to fix my issue (according to their website and google), but still no sign of it. Tried a couple of other things that I am too sleep deprived to remember but they didn't work. I then tried it in my girlfriends surface pro which displays the device in printers and devices, but will not open or prompt when clicked on (this briefly said it had no drivers but then returned to "device is operating properly"). I tried going to disk management which gave me a "connecting to virtual disk service message" error message indefinitely (waited 15 mins). I looked around the internet and saw somewhere to reinstall USB controllers, and so I tried that but when I clicked uninstall on the third option down from the disk management program's Universal Serial Bus controllers an uninstalling icon loading screen came up indefinitely. I was not able to click on anything in the computer and after 30mins the screen turned completely blue and I yanked the USB. So, I felt I had no other choice but to write a nice note begging for help.

I know my recorder still works and has the data on it, because I can playback my recordings on the device itself. I believe the physical USB connection still works as it will charge just fine. As you can probably tell, I know next to nothing about the deeper inner working of my various devices, but I'm fairly tech savvy. I would greatly appreciate someone pointing me in the right direction on how to resolve this issue.
Thank you for your time,
-M
 
Joined
Mar 30, 2014
Messages
4,766
I have witnessed a Desktop computer instantly shutdown and produce a cloud of burnt electronics smoke wafting out of the back of it when the pins in a USB port were shorted.

This Desktop computer was sitting on the floor next to the secretary's desk and had a huge wireless mouse dongle plugged into a front USB port at the bottom of the case. A mechanic came into her office and accidentally bumped that wireless dongle with his huge steel-toe boot and that's all it took. Instant silence and then the puff of acrid smoke.

Come to find out the crossed pins in the USB port and taken out (fried) the PSU, motherboard and RAM.

Fortunately the hard drive survived unscathed so I was able to swap into another computer and she was back in business.

Moral of the story: Do NOT short across two USB pins ... or across any other wires/traces inside of electronics. Doing so can allow unknown voltages to travel across circuits and through electronic components that were not designed to handle that particular voltage. When this happens it often allows smoke to escape which instantly renders those parts forever dead.
 

Johnny b

John
Joined
Nov 6, 2016
Messages
8,681
Sorry to hear about that mac.

Sounds like either a job for a repair shop or new equipment.

It's usually recommended that computers be turned off and even disconnected from an electrical outlet before doing physical work ( hardware ) on them.

Once there is a voltage spike, seeming good electronics can become unreliable and fail readily.

I had the board in an old Seagate hard drive short out on it's own.
Kapow, sparks and smoke.
I installed a new hard drive.
Two weeks later the motherboard failed.

It was time for a new computer.

You may be looking at both a replacement computer and recorder.

Have a repair shop diagnose it.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top