USB keyboard; doesn't fully work

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Zenoxio

Thread Starter
Joined
Jul 17, 2006
Messages
389
I have a USB keyboard that used to work fine, now it has problems.

Plugged in, normal keys don't work. So like letter keys etc don't work. The only keys that do work are the special keys for the keyboard (like F-lock, My Home, etc).

Any idea how to fix this? Using Windows XP SP2. I've tried restarting.
 
Joined
Apr 30, 2005
Messages
2,113
With a PS/2 keyboard go into the BIOS and enable usb keyboard support. Shut it down. Plug in the usb keyboard and see if that helps.

If you don't have a ps/2 keyboard buy one or borrow one. They can be had for super cheap now.
 

Zenoxio

Thread Starter
Joined
Jul 17, 2006
Messages
389
But if that option was off, no keys would work I think. So I don't think that is going to help.
 
Joined
Dec 9, 2000
Messages
45,855
Will the keyboard work on another computer or another USB keyboard work on this computer?

Most likey there is something amiss with the keyboard itself, but you have to test.

For driver issues, which is unlikely, you could just try doing a System Restore to a date when it worked. All you need is the mouse for that.
 
Joined
Mar 27, 2005
Messages
2,208
Remove it from the device manager and then restart.

You can also go to the manufacturer's Web site and download a newer driver for it.
 
Joined
Dec 9, 2000
Messages
45,855
Create a System Restore point and test it: Start > run: msconfig > launch System Restore

Download, unzip and run the attached file. Confirm the merge to the registry.

Then open the Device Manager, expand the key for Keyboard devices. Select View > Show Hidden Devices.

Now right click on each keyboard device and select "uninstall". When done, reboot.

If you see the New Hardware Wizard and it doesn't know where to find something, point it to:

c:\windows\INF

This assumes 'c' is your root directory. The INF folder is hidden so you need to have "show hidden files" enabled in Folder Options > View to see it.
 

Attachments

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top