USB Keyboard & Mouse Problem

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Lightingman2003

Thread Starter
Joined
Aug 14, 2007
Messages
119
I have just bought a new USB Keyboard & Mouse as our old Keyboard was PS/2 was packing up. I have followed the instructions that came with the Keyboard & Mouse (both made by Microsoft) and installed the drivers first, and then connected the devices after a reboot, but Windows did not recognise them. I tried to reboot the computer, (with them connected), but again Windows did not recognise them.

After trying all of this, i connected them via the USB - PS/2 Connectors supplied and they worked first time. They are currently connected via USB in the two USB ports on the front of the PC as they will not work on the ports on the rear.

My PC Specs are as follows:
Intel Pentium D 820 2.8Ghz,
2GB RAM
Windows XP Pro, SP3
Asus P5P800VM Motherboard.

Does anybody have any ideas?
 
Joined
Oct 17, 2007
Messages
1,099
General rule I have always told my customers when installing a new keyboard or mouse, especially USB ones - NEVER put the software in until you've tried the units in the computer first. If you're running XP (a Microsoft product) why should you need to install keyboard/mouse drivers for their own keyboard/mouse?

The thing to remember is that the drivers in Windows are 'Logitech Standard', meaning that they are the type used by the biggest manufacturer of keyboards and mice in the world... and who just happen to have received this software from the folks at Microsoft (its one of those anti-trust things). It also means guess who probably made that keyboard and mouse for Microsoft? You got it!

My suggestion would be to start over - run the System Restore to the last checkpoint prior to adding the software (this will mean you will have to re-plug in the old PS2 keyboard at least). Once there, and making sure that both new keyboard and mouse are DISCONNECTED from the computer, boot up the computer and get to the Desktop. Once everything has settled down, unplug the old PS2 keyboard and plug the MOUSE in first, and allow it to be 'found' by the system. Once this is done and (hopefully) found working, do the same for the keyboard.

The only thing you didn't tell us is if these were wireless or not. If they are wireless, then the setup is slightly different. You would plug the bob into the USB (that wireless receiver that came with the set). There is a 'Connect' button on all three devices. Press the one on the bob first, then the mouse second. Once connection has been made (determined by swirling the mouse about until the pointer starts spinning on the screen), try the keyboard and see if it registers with something like a Word document.

Good luck!

A-N
 
Joined
May 5, 2008
Messages
443
I concur with A-N. I never install the drivers for the keyboard or mouse. I just try them and they've worked. But, what's done is done.
Funny thing with this problem is that the USB connectors in the back are dead. I've seen the ones in front be dead because they were not plugged properly into the Mobo ... but the ones on the back are usually built in. They should work. :confused:
Unless maybe the ones on the back are from an add on card. Is that the case?
 

Lightingman2003

Thread Starter
Joined
Aug 14, 2007
Messages
119
The USB ports on the back are indeed on the Mobo. What also seems quite odd, the Mouse & Keyboard do not work on the rear ports, BUT my Printer and External HDD work fine and are recognised by Windows when they are plugged in etc.

However saying that, we did go through a phase of the Printer being recognised, but when we printed anything (inc Test Pages) they came out as gobblede-gook (ramdom letters and symbols etc).

Apologies, the keyboard & mouse are not wireless. I personally do not like Wireless Keyboards & Mice, they go through batteries like there is no tomorrow.

I will try going back. I will let you know how i get on.

Thanks for the help so far. :)
 

dustyjay

Jay
Joined
Jan 23, 2003
Messages
12,661
Try going into your BIOS and enabling Legacy USB support. I have had to do that for USB Keyboards and USB mouse support.
 

Lightingman2003

Thread Starter
Joined
Aug 14, 2007
Messages
119
Ah. Thanks. Did have a brief look in the BIOS, but wasnt sure what to look for. Next time im home, i will have a look.

I will reply once ive had a look.

Thanks in advance.

Lightingman2003
 

Lightingman2003

Thread Starter
Joined
Aug 14, 2007
Messages
119
Ive tried with the Legacy USB Support and to no avail. It was set as "Auto" to begin with, and i changed it to "Enabled". When i booted the PC from scratch with the new BIOS Setting, the Num Lock and mouse flashed red for a second, but they then went out and did not work. I am currently typing via them in the front of the PC again.

Any new ideas?
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Staff online

Members online

Top