1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

USB Malfunction problem

Discussion in 'Hardware' started by sandeepb, Feb 28, 2008.

Thread Status:
Not open for further replies.
Advertisement
  1. sandeepb

    sandeepb Thread Starter

    Joined:
    Feb 28, 2008
    Messages:
    12
    Hi everyone,

    I need really urgent help! If you can help me your a lifesaver!

    Well my problem:

    Whenever I connect a USB into my laptop i receive a "USB Device Not Recognized" Message.

    the notice says that the device has malfunctioned and windows does not recognize it.

    Then it turns into an unknown device.

    I have searched all over the net for a fix to this but I cannot get a working one.

    I have also tried the USB on other computers and it works perfectly fine, it's a problem with my laptop.

    I have tried my pendrive, ipod and mobile phone and all three do not work.

    Thankyou.
     
  2. bearone2

    bearone2 Banned

    Joined:
    Jun 4, 2004
    Messages:
    5,809
    operating system and info about the system helps in the fix.
     
  3. sandeepb

    sandeepb Thread Starter

    Joined:
    Feb 28, 2008
    Messages:
    12
    Vista Ultimate x86 (32-bit)

    I don't know what other info you want.

    The problem happened today out of random. It was working perfectly well yesterday.
     
  4. bearone2

    bearone2 Banned

    Joined:
    Jun 4, 2004
    Messages:
    5,809
    i don't offer anything up on vista as i'm not using it, good luck, someone will reply.
     
  5. sandeepb

    sandeepb Thread Starter

    Joined:
    Feb 28, 2008
    Messages:
    12
    O ok then.
    Thanks for the fast reply tough
     
  6. mwgw

    mwgw

    Joined:
    Jul 11, 2007
    Messages:
    7
    I have had this happen to me a couple of times, I don't have a fix but I do have a work around. This has worked for me in the past. Go to device manager and delete the unknown device that is the USB item that you plugged in. Restart your computer with the device in the usb slot windows will find it and most of the time write the correct drivers for it.
     
  7. sandeepb

    sandeepb Thread Starter

    Joined:
    Feb 28, 2008
    Messages:
    12
    So basically do an uninstallation of the unknown device from device manager. then restart my computer and it should load it up.

    Well ill try that out and edit this post if it does.

    I hope this works, i need a lot of transferring done :p lol

    Thanks,

    Edit: Didn't Work :(
     
  8. sandeepb

    sandeepb Thread Starter

    Joined:
    Feb 28, 2008
    Messages:
    12

    Attached Files:

  9. python911

    python911

    Joined:
    Oct 14, 2006
    Messages:
    71
    Were the other computers you plugged the USB mouse into running Vista? It might be an issue with Vista. It may be that the USB drivers for the mouse are not Vista compatible. Also, what make and model is the mouse?
     
  10. sandeepb

    sandeepb Thread Starter

    Joined:
    Feb 28, 2008
    Messages:
    12
    I have tried it on a different machine running the exact same OS and it works perfectly.

    And it isn't just one USB it is all the USB's I have tried plugging in, all of them return an unknown device.
     
  11. python911

    python911

    Joined:
    Oct 14, 2006
    Messages:
    71
    All I can suggest is that you find the model of your motherboard and update all the drives for it off the manufacturer's website. People seem to get unread USB devices from time to time. Have you tried another USB device on the laptop?
     
  12. sandeepb

    sandeepb Thread Starter

    Joined:
    Feb 28, 2008
    Messages:
    12
    Yes every USB device I have connected on the laptop does not work at all all of them say unknown device.

    I don't know which chipset my motherboard is, All i know it is Intel, if you look on my attachment on the above post then you can see all my system devices, if you can help me on finding that it would be great.

    Thanks for your help, I have been sitting here for over 2 hours now trying to fix it.
     
  13. sandeepb

    sandeepb Thread Starter

    Joined:
    Feb 28, 2008
    Messages:
    12
    Actually just checked now with Everest and now shows all info on my motherboard.

    It is attached on the post.

    Hope this helps finding it out.
     

    Attached Files:

  14. python911

    python911

    Joined:
    Oct 14, 2006
    Messages:
    71
  15. sandeepb

    sandeepb Thread Starter

    Joined:
    Feb 28, 2008
    Messages:
    12
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/688176

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice