USB on 98 1st edition

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

bridgeplayer

Thread Starter
Joined
Sep 16, 2003
Messages
23
I have a fairly old PC running windows 98 1st edition which uses a serial mouse. The serial port has gone phut so I thought no probs install a PCI usb card and use a usb mouse (PC does not have any on board usb)

However when install is complete (incl software) and I check device manager the usb device is not functioning

Any thoughts?
 
Joined
Feb 23, 2003
Messages
16,274
Do you have the 98 cdrom ? If so then try updating the drivers and if still no joy check in the bios for usb support enabled.
 

bridgeplayer

Thread Starter
Joined
Sep 16, 2003
Messages
23
Yes I've 98 1st edition cd and I tried updating drivers but no luck. Will get into bios and try that, may take a day as PC not where I am at present
 
Joined
Feb 23, 2003
Messages
16,274
Ok , you may have to browse around a bit but there shpuld be a setting in there somewhere and it should be set to enabled..
 

bridgeplayer

Thread Starter
Joined
Sep 16, 2003
Messages
23
USB was disabled in bios, have enabled but still no joy.

Windows did install 2 extra devices upon re-boot after enabling but the mouse does not respond.

Any further suggestions?
 

bridgeplayer

Thread Starter
Joined
Sep 16, 2003
Messages
23
This is in Device manager under USB Controller

Standard open hcdusb host controller
USB root hub
USB root hub
VIA vt83c572/vt82c586
PCI to USB host controller


When the USB Mouse is plugged in no new device is found by windows
 
Joined
Feb 23, 2003
Messages
16,274
What we may need to do is download the usb drivers for the motherboard from the manufacturer website. If you don't know the motherboard make and model then download Aida 32 which should provide both so we can look for the mobo drivers..
 

bridgeplayer

Thread Starter
Joined
Sep 16, 2003
Messages
23
mobo

Sorry to take so long to get info, but er indoors dragged me to turkey (pre footie) anyway

Results from Aida

FIC is manurfacturer
motherboard is a va502

but there is no bios or driver updates on their sit

www.fic.com.tw

next step?
 
Joined
Feb 23, 2003
Messages
16,274
I need one more piece of info: Is your processor an intel or amd ?
 
Joined
Jul 12, 2003
Messages
267
Originally posted by bridgeplayer:
This is in Device manager under USB Controller

Standard open hcdusb host controller
USB root hub
USB root hub
VIA vt83c572/vt82c586
PCI to USB host controller


When the USB Mouse is plugged in no new device is found by windows
You just need to know what chipset the usb controller uses. Usually NEC or VIA, looks like yours is VIA. Try
.Via Chipset drivers
I have both, my onbord is a VIA chipset, and my add-in PCI card has a NEC chipset. I don't remember having to load two drivers, but I think mine are detected OK during my OS install. I do end up loading the USB 2 drivers for the PCI card though, for some reason windows doesn't load them. My ADS PCI card didn't come with any drivers, no disk no CD, they didn't have any drivers on their site either. They do now though. I found the USBman site to be a good source of info and drivers
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top