USB Port fried?

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

winterain

Thread Starter
Joined
Jan 28, 2005
Messages
4
Got a problem here... was gaming as usual, suddenly computer froze.. thought it was 1 of those routine win xp freezes, so i just press restart..
next thing i know, my mouse's optical light is off, and i realize all 4 usb ports are not working....
checking in windows device manager shows that they're working fine with no conflicts whatsoever though..
but theres no response from any hardware plugged to them...
could the ports be fried ? any solution to this w/o replacing the motherboard?
:( thanks alot for any responses.
 

~Candy~

Retired Administrator
Joined
Jan 27, 2001
Messages
103,706
Hi and welcome.

You could buy an add in PCI USB card.

Have you tried removing the USB devices via device manager and see if Windows can find the ports again?
 

winterain

Thread Starter
Joined
Jan 28, 2005
Messages
4
just tried removing the USB buses from device manager, and tried the add hardware wiz... surprisingly... everything was detected...
 

~Candy~

Retired Administrator
Joined
Jan 27, 2001
Messages
103,706
Well, that would indicate that something must have happened to them. An add in PCI card can be had for as little as $10, sometimes less. I got one free after rebate once.
 

winterain

Thread Starter
Joined
Jan 28, 2005
Messages
4
hi i'm back,
something very fishy is going on! coz i went to buy a pci usb card today, and plugged it in.. it installed fine w/o any problems... i was even delighted to see my mouse's optical light up the moment i boot up the PC ...
HOWEVER .....
once in windows, windows has a little pop up that says ' There appears to be a malfunction with one of your USB devices, and windows xp is unable to detect your usb device.. bla bla " ..
But, i plug in my mouse to my 2nd computer, and it runs just fine .....
what could be the problem?
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top