1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

USB ports just stopped working !!

Discussion in 'Hardware' started by randytellis, Nov 2, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. randytellis

    randytellis Thread Starter

    Joined:
    Nov 2, 2007
    Messages:
    5
    hi guys, this problem has been plaguing me for a long time now. tried searching everywhere but none of the solutions seem to be working. My USB ports were working fine until one day when i uninstalled my HP printers drivers and software. It doesnt show any problem in the Device Manager(i.e no exclamation marks) but devices seem to be drawing power from the ports, only windows does not detect these devices. When i plugin any device, i don't get the sound which i usually do nor a popup from the system tray. Plz guys help me out as I;m really really stumped.
    Im using Windows Xp Proffessional with SP2.
     
  2. jazz3000

    jazz3000

    Joined:
    Apr 19, 2007
    Messages:
    2,503
    Go into Bios and make sure they are still enabled. Go in Device manager and delete them.
    Reboot and let windows Identify them again. And then test them out. Let us know...Jazz
     
  3. randytellis

    randytellis Thread Starter

    Joined:
    Nov 2, 2007
    Messages:
    5
    hey thnks for ur reply but I've already done that. Its Enabled in the BIOS but when i try deleting them from device manager, my system just hangs and I have to manually shutdown Device Manager via the taskmanager. Any more help would be deeply appreciated.
     
  4. jazz3000

    jazz3000

    Joined:
    Apr 19, 2007
    Messages:
    2,503
    The only other thing I've heard about outside of just complete hardware failure is that when certain applications - like HP- are uninstalled certain residuals of the program stay in memory and can cause usb ports to stop working.
    It's suggested that you shut the machine down and literally unplug it from the wall for 4 or 5 minutes and then re-establish the power source and reboot. It's suppose to clear the memory banks hanging onto the residuals.
    If it clears them you will need to uninstall and reinstall them again so you don't wind up having the same problem. Interesting that your system hangs. I hope this works. Let us know...Jazz
     
  5. randytellis

    randytellis Thread Starter

    Joined:
    Nov 2, 2007
    Messages:
    5
    Done that already. Whenever I do that, after startup I get >>New Device Detected>Installing USB Root Hub and then it's back to the same old story.
    I'll be installing Windows Vista tomorrow and was wondering will the problem still persist or will it be fine with a format and fresh installation.
     
  6. bodhost.co.uk

    bodhost.co.uk

    Joined:
    Aug 9, 2007
    Messages:
    82
    If you are installing a new OS means a vista it will automatically install all the drivers required for your pc and if you still face the same problem let us know.
     
  7. jazz3000

    jazz3000

    Joined:
    Apr 19, 2007
    Messages:
    2,503
    I'll tell you what- If the HP software has never been totally removed, formatting and installing a new OS may well do the trick. It will clean anything out of the registry, etc., that might be causing the problem. If that doesn't do it I guess I'd be looking for some new ports. Something is definitely wrong if when you try to uninstall and reinstall the ports, your system is freezing up. We'll hope a fresh install of everything is all you need.
    The only other thing I can offer at this point is going to the url below, an downloading the Free Registry Cleaner and running it to make sure it's not something within the registry itself causing the issue... It's a good little program and it's free even though you're allowed to donate if you chose. Works well for me with a lot of little things.

    http://www.eusing.com/free_registry_cleaner/updatev16.htm
    Let us know what happens...Jazz
     
  8. randytellis

    randytellis Thread Starter

    Joined:
    Nov 2, 2007
    Messages:
    5
    Well guys, I formatted my hard-drive, installed Vista, the USB drivers installed properly but the same problem, so I guess it's a hardware problem or correct me if I'm wrong. But devices draw power from the hubs which is the part i don't understand.
     
  9. ProWFP

    ProWFP

    Joined:
    Mar 24, 2007
    Messages:
    58
    Correct, but, 10 seconds is enough, Asus mobo's with green LEDs signal you when they completely loose power (LED turns off) and that means no power is going through your system.
     
  10. jazz3000

    jazz3000

    Joined:
    Apr 19, 2007
    Messages:
    2,503
    Randy this is suppose to help if the usb's stop working unexpectantly. I had no idea until today this was even there. Try it - I hope it works for you. If not I'm thinking it must be the hardware...Let us know...Jazz

    o Click Start, and right-click My Computer.

    o Click Properties, then click Hardware.

    o Click Device Manager.

    o Double-click the Universal Serial Bus Controllers branch to expand it.

    o Right-click USB Root Hub, and then click Properties.

    o Click Power Management.

    o Deselect Allow the computer to turn off this device to save power.

    o Repeat Steps 5 through 7 for each USB Root Hub.

    o Click OK, and close Device Manager.
     
  11. randytellis

    randytellis Thread Starter

    Joined:
    Nov 2, 2007
    Messages:
    5
    hey guys am back ^_^. I bought a new cabinet and set it up perfectly and the USB port's were working fine until i plugged in the HP printer again. After i removed the printer my usb ports stopped working again. Only my Sony Ericsson Phone works through the USB that too after going to the BIOS and Enabling all USB's even though it shows Enabled. Im in a fix now as I can't change my cabinet again. :confused:
     
  12. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/646835

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice