USB Ports Not Reading (Toshiba Satellite C850)

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

prototype112

Thread Starter
Joined
Feb 6, 2013
Messages
1
Hi
So I have absolutely no idea what's going on.I'm not the best with computers. Anything I put in the USB ports, HDMI cables, USB's, my mobile phone, none of it will read. There's no notification sound, nothing that pops up and says it can read whatever I just put in, literally nothing. Like no noise, or any sign that the computer read it. I checked the device manager, and all the ports, installed them and uninstalled and enabled them etc. I downloaded new updated drivers for it too, but it says it's already up to date. The ports aren't damaged that I can see. How do I fix it if Windows is insisting that I'm up to date and the ports are there? Please help! Thank you in advance.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top