1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Usb ports not working for any mouse!!

Discussion in 'Windows XP' started by Supernova25, Aug 12, 2008.

Thread Status:
Not open for further replies.
Advertisement
  1. Supernova25

    Supernova25 Thread Starter

    Joined:
    Aug 12, 2008
    Messages:
    7
    Hi All,
    I have a machine which has suddenly stopped responding to any mouse connected to the usb port. The ports appear to still be working as i can access a usb key etc from them. As soon as i plug a mouse in i get an error saying the device may not be installed properly. When checking in the control pannel all devices appear to be fine but the port the mouse is in shows as 'unknown device' it seems to have suddenly lost the ability to recognise when something is a mouse??? im absolutely baffled....
    I have tried:
    -Last known good configuration
    -Different mouse
    -Disabled/re-enabling ports
    -uninstalling/reinstalling ports
    -Different USB connections

    Still no difference at all! as the ports are working for usb keys does it sound like a software issue instead of hardware??? i guess a rebuild would be a last resort but due to the amount of data etc any help/suggestions on how to resolve this issue would be great!!

    I sounds simple as it sees the device just not that its a mouse! The machine is XP to.....

    Thanks in advance,
     
  2. Techmonkeys

    Techmonkeys

    Joined:
    Feb 10, 2005
    Messages:
    625
    Could be that your power supply is failing, meaning it cannot get enough power to the mouse to use it, but that seems strange with it saying "unknown device".

    Is it possible for you to try a powered USB hub? can you borrow one off someone?

    What about other USB devices? Joystick? Keyboard etc?
     
  3. Supernova25

    Supernova25 Thread Starter

    Joined:
    Aug 12, 2008
    Messages:
    7
    All other usb devices seem to work fine - i dont think its a power issue as its only mouse affected....

    When it boots up the infra red under the mouse is lit up but when it reaches the win login screen it goes off.....

    it is a weird one!!
     
  4. Techmonkeys

    Techmonkeys

    Joined:
    Feb 10, 2005
    Messages:
    625
    Are any events being logged in event viewer ?

    I found people with the same issue, but none with the answer, so we will have to try and figure it out.

    Have a look in event viewer for any errors that occur when you plug the mouse in.
     
  5. Supernova25

    Supernova25 Thread Starter

    Joined:
    Aug 12, 2008
    Messages:
    7
    will do,
     
  6. Supernova25

    Supernova25 Thread Starter

    Joined:
    Aug 12, 2008
    Messages:
    7
    Right,

    Have updated to service pack 3 - thought this would have sorted out the mouse drivers - still no luck!!!

    Basically.... I now have a ps2 mouse/keyboard working, and any other usb device APART from mouse or keyboard.....

    Are the usb drivers for usb mouse/keyboard generic and part of windows????

    OR

    do i need to install some sort of motherboard driver for the specific motherboard??? really need some help on this one!!!

    ta
     
  7. muppy03

    muppy03 Malware Specialist

    Joined:
    Jun 19, 2006
    Messages:
    1,879
    Every time a USB gadget is plugged into a computer then removed it leaves a ghost of itself behind. This confuses windows sometimes.

    Try this
    • Right click my comp then choose properties then choose advanced tab.
    • Click on environment variables down at the bottom of the page.
    • Choose new in the SYSTEM variables box. (if you choose User box the changes are only made to that particular user)._
      A new Box will open..
    • In Variable name type: DEVMGR_SHOW_NONPRESENT_DEVICES
    • In Variable value type: 1
    • Then click ok, ok and ok..

    Now open up device manager. To do this Right click my comp choose properties then choose hardware tab then click on device manager. When device manager opens , click view(at the top} then select show hidden devices.

    Device manager will now show the usual hidden devices and the Ghosted ones. The Ghosted ones are recognisable as they are shadowed/greyed out.
    Expand Mice and other pointing Devices by clicking on the + sign. You might see several entries relating to your mouse . Right click these entries and uninstall. Do the same for Keyboard

    Now unplug ALL USB devices and reboot . Have a nice clean stack of USB’s available.

    Once rebooted the Mouse should be recognised again.

    edit: make sure you also uninstall the 'unknown device'
     
  8. Supernova25

    Supernova25 Thread Starter

    Joined:
    Aug 12, 2008
    Messages:
    7
    Thanks for that - unfortunately it didnt work.....entered new variable but it doesnt bring anything else up in the control pannel...all it shows under mice etc is the PS2 one im currently having to use....still no joy....

    regards..

    frustrated... lol
     
  9. muppy03

    muppy03 Malware Specialist

    Joined:
    Jun 19, 2006
    Messages:
    1,879
    did you click on show hidden devices? after expanding the mice etc
     
  10. Supernova25

    Supernova25 Thread Starter

    Joined:
    Aug 12, 2008
    Messages:
    7
    hmm. i didnt! but this time i did! i deleted ALL entries in there and also ALL the entries under the usb for unknown device etc... rebooted...connected mouse and it says "found new hardware" which gave me hope but then "unknown device" comes up!! ggrr!
     
  11. muppy03

    muppy03 Malware Specialist

    Joined:
    Jun 19, 2006
    Messages:
    1,879
    its all good, do it again make sure all traces of the mouse are gone, also check there is no 'other devices' as well as the 'unknown devices. you can then expand your usb's and uninstall all of them. When you reboot they will all automatically be re-installed. See if that gets the mouse going.
     
  12. Supernova25

    Supernova25 Thread Starter

    Joined:
    Aug 12, 2008
    Messages:
    7
    there are no other devices at all - just tried it a second time - it picks it up as new hardware but just unknown each time... it recognises other devices such as memory keys fine....
     
  13. muppy03

    muppy03 Malware Specialist

    Joined:
    Jun 19, 2006
    Messages:
    1,879
    did you do the above without the ps2 mouse plugged in? if not try, also expand usb and uninstall all the ghosted entries of unknown devices
     
  14. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/739274