1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

USB Ports Not Working

Discussion in 'Windows XP' started by Frank4d, Jan 4, 2009.

Thread Status:
Not open for further replies.
Advertisement
  1. Frank4d

    Frank4d Retired Trusted Advisor Thread Starter

    Joined:
    Sep 10, 2006
    Messages:
    9,126
    I am working on a friends laptop, a Dell Inspiron 9200 running Windows XP Pro with SP3. I have it working well now except the USB ports do not work.

    The laptop was in pretty bad shape when I started. I remove Norton Antivirus (subscription expired 3 years ago), removed a few trojans and viruses using Malwarebytes and Combofix, and installed AVG Free. I also cleaned up the temp files, compacted the registry using NTRegOpt, and defragmented the drive.

    I have tried uninstalling the USB controllers and let Windows reinstall them, verified working status in Device manager, and disabled USB device power management. I also plugged in a USB mouse and verified the ports are supplying power.

    I should add that the USB ports did not work before any of the above, but I know they worked two years ago. Ideas?
     
  2. TOYMAN1952

    TOYMAN1952

    Joined:
    Jun 10, 2001
    Messages:
    160
    Maybe you have already done this but check that your USB is enabled in your BIOS
     
  3. devil_himself

    devil_himself

    Joined:
    Apr 7, 2007
    Messages:
    4,910
  4. Frank4d

    Frank4d Retired Trusted Advisor Thread Starter

    Joined:
    Sep 10, 2006
    Messages:
    9,126
    USB is enabled in the BIOS and Device Manager shows them as working. I have also tried the two MS support links.

    I will see if I can get my son to help with the Knoppix Live CD. It runs right off the CD right? I don't want to hose my friends hard drive.
     
  5. devil_himself

    devil_himself

    Joined:
    Apr 7, 2007
    Messages:
    4,910
    yea, Knoppix runs off the CDROM drive, but never tried it.
     
  6. devil_himself

    devil_himself

    Joined:
    Apr 7, 2007
    Messages:
    4,910
    have u tried reinstalling the drivers for the motherboard. you may need those for USB to work.

    remember if your device is usb2.0 then you need to check whether you have host controller for this latest version of USB2.0
     
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/786606

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice